SMTP not working properly

I tried to send an email from my phone, but I get “Authentification failed”.

I use no authentification at all! My phone connects to the SMTP server over WLAN or VPN tunnel to my local mail server, so I actually do not need any kind of SMPT authentification.

Settings showing up in k9-Mail are correct, it also worked in the past, but now it does not any more.


As I said in:

this should work, given the correct settings (which may be different in your case from those in that item). If it fails, look at your server’s logs and see what it is reporting.

This is a bug. See SMTP without authentication stopped working with v5.805

Why can’t developers let perfectly working things untouched…
When I select no authentification - why is the (currently not working) stuff involved at all? Why isn’t it skipped?

The same with screen colors. This new color scheme is a nightmare. New mails have only a very little brighter background than read ones.
In sunlight, you have absolutely no chance to differentiate. → Change things only for having changed something

Because things stop working when Android is updated and the app isn’t.

Because the server connection needs to be skipped when the account is not properly set up yet. There was a bug in the detection wether an account is properly set up.