Doesn't download new mail

Doesn’t download new mail automatically - although it might do a poll (it seems), and at some point not even when doing a manual check.

(Interesting that the forum software suggest similar topic already posted, but that old one had no reply…)

Version info etc: K-9 Mail 6.802. Android 13.
General settings: Network > Background sync: Always.
Account: Poll freq. 15 min.
(As for Notifications, all are enabled for K-9.)

This is a bit frustrating troubleshooting, since behaviour isn’t consistent and change over time (it seems).

I’ve been a happy user of K-9 Mail for more than 10 years; although nothing advanced, a couple of email accounts, IMAP, no push (more about a test with that in this troubleshooting below), since mobile data/Wi-Fi isn’t always on I’ve historically often opened the mail client/app and done a manual check. That has worked fine, until recently.

More recently, some months ago, I changed the Network setting in K-9 (Background sync) to Always, and it worked great (without having Android setting: Passwords & accounts > automatic sync enabled, since that is for other apps etc). But then it started getting showing signs of problems; didn’t download all, more below.

I’m doing this troubleshooting on a new mobile (with K-9 6.802) set up some week ago, and I imported settings from an old running 6.801. I don’t think this export/import has anything to do with the problem, since it worked very well the first days/week with the new mobile.

On the old mobile I started getting a minor problem some months ago: a manual poll wouldn’t download emails sent to an alias for the main account (weird, since alias is only interesting for sending, incoming end up in the same mail box on the server, so K-9 should download all), or perhaps this wasn’t only about mail sent to the alias but all, but I didn’t notice.

When it was working as it should, as soon as Wi-Fi/mobile data was enabled K-9 did an initial first poll, as can be seen at the top of the screen (quick spinning wheels), and if nothing it would then try again at the frequency set for the account. Both notification and sound worked, now I get nothing, and it doesn’t pull down even during a manual check. However in later tests it does. (On the new mobile, this depends on ver of Android, one can also see which apps has sent recent notifications, in Settings > Notifications > Recently (or similar), i.e. even if there were no mail, Android notice that K-9 had it’s icon up there X minutes ago.)

Yesterday I had sent some test mail, K-9 wouldn’t download, I then did some other work on both old and new mobile and enabled Wi-Fi on the old, and it directly pulled down the test mail… notification, sound and all.

Today I briefly did a test with Push on the new mobile, didn’t seem to work, first time around (I didn’t have to change much, Manage folders > Inbox was “1st Class”, and the I set Push to “Only 1st Class”.)

Did another try, and it was working, with some minute delay.
Disabled Push.

Sent a new test mail (always from comp), Wi-Fi disabled on mobile, enabled Wi-Fi and K9 didn’t do an initial check. Manual check downloaded the mail, though.

A week ago I would have got a notification (sound and all).

Another test (Poll freq. for this account 15 min.): Sent new mail from comp, Wi-Fi disabled on mobile, enabled Wi-Fi and K9 didn’t do an initial check. Waited almost 20m to see what happens … Nothing, manual check and it’s downloaded.

What is going on?

So, what has changed? That’s always difficult to tell, when you don’t know which things have an effect on each other (i.e. OS settings vs app). Quite new mobile as I said; after some days I enabled the Adaptive Battery setting and handle background apps under Battery (but not the third option using “AI”). But since I thought this might interfere with K-9, I disabled both settings again (on the other hand, at some point K-9 didn’t download during manual check either so…).

Some days ago I also installed the most recent Android security update; the mobile has been restarted twice since then I think. Android 14 is waiting, but I’m not going to upgrade for a while.

Guess some will try to convince me to use Push, but it has been working without it before, doing an initial check as soon as mobile data/Wi-Fi is enabled and then polling at req. freq.

So what can I check?

Hrm. For both the Fetching Mail and Sending Mail setting groups for this account, go to both the Incoming Server and Outgoing Server items and see if you can walk through it’s test of the connection to your mail host.

Just tap Next. If it works, you should be back at the Settings menu.

Thanks for reply. I did this today, i.e. walk through the steps (only for this account as a start), checking with “Next”, returning to Settings and then for Sending.

When I imported the settings to the new mobile last week I did this sort of, and I noticed then that I had to (obviously) add passwords (they are not included in the backup, and several years since I last did this export/import). And it worked for some days. In today’s exercise I noticed that I hadn’t put in a Username (for account) for Sending server during the import. I did so today, clicked Next and it went through.

I then sent a test mail (had not done that from the new mobile yet), and waited.

Previous test mails were sent from a computer, and the PC use POP so in those cases I had to make sure the mail client was offline after sending so that it wouldn’t do a poll before the mobile. In this test the PC email client was in offline mode.

As mentioned for this account K-9 is set to 15 min. I waited 25, then did a manual check. Nothing …

Then did a check with PC mail client and it downloaded the test mail …
So, I can send a mail from the mobile, but it can’t poll at requested frequency, and it can’t find a new mail when there is one. That’s next to useless. :frowning_face:

Now it’s working - sort of. I will not say that we have a solution, or the issue being solved for good, yet.

So far:
I’ve done a couple of more tests, wish I had used a more systematic approach in the troubleshooting, but as per above tried sending from PC with wifi/data link enabled and no poll, no notification, but download on manual check. Then sending from PC with wifi/data link disabled to test if doing an initial poll when wifi was enabled, but nope.

(Also tried with both the email address and the alias, but that shouldn’t matter.)

In Settings, under info for the app, K-9 Mail, in Android, under Notifications all are enabled, as they’ve always been, for all accounts and the rest. For the individual accounts notification settings are in standard settings. However, I changed one, and only for the account I’m testing at the moment. I enabled the first setting: show on screen when device is unlocked. (As per usual it’s not always obvious what all settings change, but I changed only this one, for now.)

I sent another test mail from PC, enabled wifi on mobile, nothing, started K-9, nothing (but didn’t do a manual check), then when phone was idle and screen locked I suddenly got a notification (and sound) on the lock screen, aprox. 7 minutes after sending (from PC).

Odd.

I then tested with Push, and it worked (notification and sound on locked screen).
Disabled Push.

Sent another test mail, aprox. 13 minutes past the hour, did nothing to K-9 or the mobile, left it idle at lock screen, then 24 minutes later a chime and there it was, a notification on the lock screen and the latest test mail in K-9.

Another test (getting a bit bored testing different scenarios for something basic that just should work); K-9 left running, but with wifi disabled (I use wifi for these tests), to again see if doing an initial poll when enabled: test mail from PC, unlocked mobile, enabled wifi, and left phone, downloaded and with notification (with sound) within 5-10 min after sending.

And finally another test; wi-fi enabled, phone left idle, mail sent from PC, and more or less exactly 15 minutes later a chime and a notification on the mobile.

So, it seems to work, now. It did so first days after installation. As mentioned, over a couple of days I had enabled some general battery saving settings (not per app), later disabled again, and installed a security update, that’s about it. And also as mentioned in this post, I changed one notification setting for one account (show on screen when device is unlocked), I haven’t done that for the other e-mail accounts so I can test this further if I want.

I appreciated that K-9 always seemed to do an initial check as soon as a data link was enabled and then stuck to the req. frequency for polls, which was and is what I’m trying to get back. (If I want less than 15+ minutes I guess I could move to Push.)

So, I guess I’ll see how it will work with e-mails from other, and how my other accounts will work.

I really can’t say it’s working (as I would like, and I believe it has done before).

I was expecting an email (confirmation of something, so sent from another account to the one I’m testing now); deliberately left PC e-mail client (POP) in offline mode so not to download.

After 30+ min nothing on the new mobile (Android 13, K-9 6.802), with wi-fi enabled, being idle, when I check the lock screen. Enabled wi-fi on old mobile, K-9 wasn’t running (or in the list of recent apps), but bang, as soon as a data link was enabled it downloaded the mail …

Back to the new mobile, I log in and after a couple of seconds there is a notification (with sound), and the mail is there in K-9. But I would expect it to fetch it at some point during those 30 minutes.

I don’t know what is going on. At some point, as per above, K-9 didn’t download an email, just sent with K-9, during a manual check, and then this. I don’t know if Android is doing something, but a mobile with an active data link shouldn’t go into some kind of sleep during just 30 min. The whole point is that I should not have to log in to the mobile.

(There is a per app battery settings in Android, I haven’t touched anyone of those, but for K-9 (and most other) it is set to “optimized”, the other options are “unlimited” and “limited”. I can’t believe I should have to change this to “unlimited”.)

On the problematic phone, under the Settings for Fetching email, what are the values each for:

  • Folder poll frequency
  • Poll folders
  • Push folders

And how do those compare to the good phone?

You should always always change that to unlimited/unrestricted for apps that need to work in the background. Whatsapp, k-9, Telegram … anything that needs to be able to receive notifications (or work/measure something continuosly, like Battery Guru) while the device is idle/sleeping.
If your device has a seperate setting for background activity then that should be allowed for k-9 too.

For the account I’m testing (I have other email accounts that, at least for now, have freq. always set to “never”, i.e. they will only do a poll if forced, or if I force all accounts.):

[I assume all these settings were carried over when I imported settings from my K-9 backup of settings on the old mobile. At least that was the point, together with email accounts, but in general I haven’t changed much in K-9 over the years, at least not related to this; perhaps size of messages, number of local messages etc. and as mentioned above a couple of months ago, first on old mobile, “Network setting in K-9 (Background sync) to Always” so that it would fetch at req. frequency instead of me forcing a poll.]

  • Folder poll frequency: 15 minutes.
  • Maps to check (poll folders?): only 1:st class.
  • Push folders: none.

The “good” (old) phone (that at least seems to work with initial poll (when data link becomes available) as per above, and otherwise (but had some minor problem earlier fetching mails sent to an alias) [Some flavour of Android 8; updated to K-9 6.801 some time before the new mobile arrived.]:

  • Folder poll frequency: 30 minutes. (I changed this to 15 min on the new mobile, early in troubleshooting or post install.)
  • Maps to check (poll folders?): only 1:st class.
  • Push folders: none.

So, essentially the same. In some tests, above, I did enable Push for 1:st class folders on the new mobile. (I’m not exactly sure how this 1:st and 2:nd works, guess I need to do some reading there; but that shouldn’t be needed for the basics to work.)

Thanks for reply. I hear what you say, and since I mentioned it I have thought about it. I will have to do some separate tests with that later; the problem is that they all take time… :slight_smile: At least if you are testing without Push (15 min being minimun); and have to take notice of any differences. But I simply can’t believe that one should have to change such a setting, given the fact that this is more or less what everyone does, use messages services and email clients (and a majority seems to be on Android 13 at the moment).

That said, if we assume that K-9 is fine, working all OK, settings are OK (and were carried over without corruption) then the suspicion goes in the Android 13 direction. That is, old mobile is running 8, and new (with some problems it seems) is running 13 (“soon” 14). There can at times be downsides with “smart” functions, trying to predict what you are doing, how you are using something. And it’s not exactly easy to find information about what, for example, battery saving settings does. (The only thing it says is that “limited” might delay notifications, but that’s obvious.)

And as I type this an email (from someone) arrives on the mobile… :slight_smile: I have more tests to do, apparently.

I just want it to be as agile as on the old mobile (after I enabled Background sync to Always); i.e. even if not running (although as we know apps can be running in the background even if not visible in the list of recent apps) it should do an initial check as soon as a data link is enabled (that’s how sms messages work, leave flight plane mode and it will download, no matter if the Messages app is “running”), and it should fetch every 15 min.

Just because emails sometimes arrive, it doesn’t mean it’s working …

Just did another test (no changes in settings):
New mobile: wifi on since some hours, sent a test mail with K-9 to myself, waited 17 minutes with it being idle, nothing.

Old mobile: no K-9 running, enabled wi-fi, and it immediately pulled down the test mail

Back to new mobile: log in, move to K-9 and do a manual check, and there it is.

It’s not reliable.

(This could very well be something with the OS/Android, but try get some support there …)

I give up.

Changed Android setting on the new mobile for K-9, under Settings > Apps > K-9 Mail > “Battery” from standard setting “Optimized” to “Unlimited”.

Restarted the mobile.

Sent a test mail from the PC, and put the mail client in offline mode after (since POP), and did a manual check in K-9 on the new mobile, nothing, but it did spin the wheel for some time. Enabled wi-fi on the old mobile and did a manual check with K-9 there, same, nothing.

Did a manual poll from the PC email client and received my test message.

I don’t know what this is; a timing issue; mail just doing a round within the same ISP/email provider and thus doesn’t get downloaded, or what.

New Android versions have been (and will be) getting more and more restrictive by Google. They keep limiting everything, esp. non-Google apps - it’s getting outright ridiculous what hoops we have to jump through to get + keep things working. I originally switched to K-9 yearssss ago because even Googles own Gmail didn’t notify me of new emails on a new phone, either very late or sometimes not at all. I’ve since then tested the Gmail app on every new phone I got and things never changed, even with battery optimization for it disabled. K-9 was and still is the only email app (and I tested several others over the years) that is reliable and notifies me in a timely fashion.

As to battery optimization: I have several apps that need it disabled, Whatsapp, Telegram Battery Guru - basically any app that needs to keep functioning/notifying me even when the device is asleep. Otherwise I just get any notifications when I turn on the screen and that is usually hours after they actually happened/arrived.

If manually checking for mail doesn’t fetch new messages it means either there’s no new messages on the server or there’s a problem with checking mail that is completely unrelated to periodic mail checks not running when they should.

You could record a debug log when manually checking for mail doesn’t fetch a new message when it should. See LoggingErrors · thunderbird/thunderbird-android Wiki · GitHub

Hello, and thanks for reply. Yes, I realise that (and in this troubleshooting, not receiving during a simple manual check, as happened at some point, adds another layer of frustration). Did another similar test (no changes in settings in K-9 or Android) from PC to mobile, with manual check, this time with debug logging enabled. This time it fetched the test mail, of course it did, so all working there and this time.

Did a quick check on the exported debug log; boy that was verbose. :slight_smile: Guess I expected only the handshake - OK - questions etc. (although some part was hidden in this, which is good, there is an alternative debug log if I understand things correctly). Anyhow, this time the mail was fetched. But I will check with the e-mail service provider if there is something I’ve missed (obviously, server, protocol, port, account username & passwords are all correct, if they can add any info.

When everything [trying not to put blame in one place, when I don’t know] is working, and you get notifications as you want, it’s very nice to use K-9.

A follow up. It* has been working the last 24 hours, fetching mails both via mobile data and wi-fi (without doing manual checks). They often arrived within 10-15 minutes or so, at some point perhaps a bit longer.

*Not blaming K-9, “it” as in “everything”, as we know, and as touched on above there is plenty more involved, for a start there’s a server on the other end, and there’s the mobile’s OS and its settings.

It failed to fetch mail during a manual sync this afternoon (so, we can for the moment forget about sync at a certain freq. As you said “unrelated to periodic mail check”).

It is this intermittent behaviour that got me doing the tests mentioned above.

Mobile had been idle and not used all day; enabled Wi-Fi, and did a manual check for the main account. Spinning wheel for quite some time, but nothing (this is I assume similar to what I’ve seen at times (after I had set it to do background checks some months ago on the old mobile, a setting I carried over to the new) in the notification bar, i.e. when K-9 struggles to fetch in the background, a spinning wheel). Did some more attempts, and then checked that there indeed was an internet connection, using the web browser.

I decided to log the next attempt (I made one log 12 May, mentioned above, but then it was successful). Again, it didn’t fetch. Exported the log. Checked mail with my e-mail client on the computer (as mentioned using POP), and there were a couple of mails waiting.

It seems K-9 fails to log in. What could be the cause?

A bit down when doing the sync:


05-14 15:33:58.111 12050 12071 I MessagingController: Running command 'synchronizeMailbox', seq = 236 (background priority)
05-14 15:33:58.113 12050 12071 D MessagingController: Last folder list refresh @ tis maj 14 03:24:26 CEST 2024. Refreshing now…
05-14 15:33:58.116 12050 12071 D RealImapConnection: Connecting to imap.example.example.ex as imap.example.example.ex/00.000.0.00
05-14 15:33:58.117 12050 12071 D TrafficStats: tagSocket(150) with statsTag=0xffffffff, statsUid=-1
05-14 15:34:02.219 12050 12071 E RealImapConnection: Failed to login, closing connection for conn150724546
05-14 15:34:02.221 12050 12071 E MessagingController: com.fsck.k9.mail.MessagingException: Unable to get folder list.
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.RealImapStore.getFolders(RealImapStore.kt:96)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.backend.imap.CommandRefreshFolderList.refreshFolderList(CommandRefreshFolderList.kt:17)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.backend.imap.ImapBackend.refreshFolderList(ImapBackend.kt:51)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController.refreshFolderListSynchronous(MessagingController.java:393)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController.refreshFolderListIfStale(MessagingController.java:582)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController.synchronizeMailboxSynchronous(MessagingController.java:570)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController.lambda$synchronizeMailbox$5(MessagingController.java:545)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController.$r8$lambda$NXcAHKHxc3W1kfUNmHwjp7ep8xc(MessagingController.java:0)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController$$ExternalSyntheticLambda20.run(R8$$SyntheticClass:0)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController.runInBackground(MessagingController.java:216)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController.-$$Nest$mrunInBackground(MessagingController.java:0)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.controller.MessagingController$1.run(MessagingController.java:157)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at java.lang.Thread.run(Thread.java:1012)
05-14 15:34:02.221 12050 12071 E MessagingController: Caused by: java.net.SocketException: Connection reset
05-14 15:34:02.221 12050 12071 E MessagingController: 	at java.net.SocketInputStream.read(SocketInputStream.java:191)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at java.net.SocketInputStream.read(SocketInputStream.java:143)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.android.org.conscrypt.ConscryptEngineSocket$SSLInputStream.readFromSocket(ConscryptEngineSocket.java:983)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.android.org.conscrypt.ConscryptEngineSocket$SSLInputStream.processDataFromSocket(ConscryptEngineSocket.java:947)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.android.org.conscrypt.ConscryptEngineSocket$SSLInputStream.readUntilDataAvailable(ConscryptEngineSocket.java:862)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.android.org.conscrypt.ConscryptEngineSocket$SSLInputStream.read(ConscryptEngineSocket.java:835)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at java.io.BufferedInputStream.fill(BufferedInputStream.java:239)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at java.io.BufferedInputStream.read(BufferedInputStream.java:258)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.filter.PeekableInputStream.peek(PeekableInputStream.kt:31)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.ImapResponseParser.readResponse(ImapResponseParser.java:37)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.ImapResponseParser.readResponse(ImapResponseParser.java:29)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.RealImapConnection.readInitialResponse(RealImapConnection.kt:213)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.RealImapConnection.open(RealImapConnection.kt:89)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.RealImapConnection.hasCapability(RealImapConnection.kt:663)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.RealImapStoreKt.getSupportsListExtended(RealImapStore.kt:333)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.RealImapStoreKt.access$getSupportsListExtended(RealImapStore.kt:1)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.RealImapStore.listFolders(RealImapStore.kt:119)
05-14 15:34:02.221 12050 12071 E MessagingController: 	at com.fsck.k9.mail.store.imap.RealImapStore.getFolders(RealImapStore.kt:84)
05-14 15:34:02.221 12050 12071 E MessagingController: 	... 12 more
05-14 15:34:02.222 12050 12071 I ImapSync: Synchronizing folder Example:INBOX
05-14 15:34:02.223 12050 12071 V ImapSync: SYNC: About to get local folder INBOX
05-14 15:34:02.223 12050 12071 V ImapSync: SYNC: About to get remote folder INBOX
05-14 15:34:02.224 12050 12071 V ImapSync: SYNC: About to open remote folder INBOX
05-14 15:34:02.229 12050 12071 D RealImapConnection: Connecting to imap.example.example.ex as imap.example.example.ex/00.000.0.00
05-14 15:34:02.230 12050 12071 D TrafficStats: tagSocket(174) with statsTag=0xffffffff, statsUid=-1
05-14 15:34:06.313 12050 12071 E RealImapConnection: Failed to login, closing connection for conn110083442

If I compare the first part with the log from a successful attempt at both login and fetch of, in that case, a test mail, the other day:

05-12 16:28:20.163  9034  9068 I MessagingController: Running command 'synchronizeMailbox', seq = 36 (background priority)
05-12 16:28:20.164  9034  9068 D MessagingController: Last folder list refresh @ sön maj 12 15:55:54 CEST 2024. Refreshing now…
05-12 16:28:20.170  9034  9068 D RealImapConnection: Connecting to imap.EXAMPLE.EXAMPLE.EX as imap.EXAMPLE.EXAMPLE.EX/00.000.0.00
05-12 16:28:20.171  9034  9068 D TrafficStats: tagSocket(114) with statsTag=0xffffffff, statsUid=-1
05-12 16:28:20.254  9034  9068 V RealImapConnection: conn135378778 <<< #null# [OK, [CAPABILITY, IMAP4rev1, UIDPLUS, CHILDREN, NAMESPACE, THREAD=ORDEREDSUBJECT, THREAD=REFERENCES, SORT, QUOTA, IDLE, ACL, ACL2=UNION, STARTTLS], Courier-IMAP ready. Copyright 1998-2017 Double Precision, Inc.  See COPYING for distribution information.]
05-12 16:28:20.254  9034  9068 D RealImapConnection: Saving [NAMESPACE, ACL2=UNION, QUOTA, IMAP4REV1, IDLE, THREAD=REFERENCES, SORT, ACL, STARTTLS, THREAD=ORDEREDSUBJECT, UIDPLUS, CHILDREN] capabilities for conn135378778
05-12 16:28:20.255  9034  9068 V RealImapConnection: conn135378778>>> [Command Hidden, Enable Sensitive Debug Logging To Show]
05-12 16:28:20.284  9034  9068 V ImapResponseParser: conn135378778<<<#1# [OK, LOGIN Ok.]
05-12 16:28:20.284  9034  9068 I RealImapConnection: Did not get capabilities in post-auth banner, requesting CAPABILITY for conn135378778
05-12 16:28:20.285  9034  9068 V RealImapConnection: conn135378778>>> 2 CAPABILITY
05-12 16:28:20.291  9034  9068 V ImapResponseParser: conn135378778<<<#null# [CAPABILITY, IMAP4rev1, UIDPLUS, CHILDREN, NAMESPACE, THREAD=ORDEREDSUBJECT, THREAD=REFERENCES, SORT, QUOTA, IDLE, ACL, ACL2=UNION]
05-12 16:28:20.291  9034  9068 V ImapResponseParser: conn135378778<<<#2# [OK, CAPABILITY completed]

The debug log indicates that the TCP connection was reset (closed) when the app tried to read the initial greeting from the server. This can have a number of reasons and could be anything from some firewall software on your Android device, the networks between you and the server, to the server itself.

It’s somewhat odd that the connection seems to have been successfully established and then reset right away. Usually, when there’s connectivity problems, the connection won’t be established at all. So it’s probably something actively interrupting the connection.

Yes, it’s odd. (I haven’t yet talked to the e-mail service provider.) Apart from what is going on on the server side and perhaps Android, I can’t think of anything but VPN (and perhaps Wi-Fi hardware differences between the mobiles). But VPN is enabled and there in the background all the time. And both mobiles use the same VPN solution, so no difference there. As mentioned above, before I did another attempt with a debug log enabled 14 May, I checked the Internet connection with a web browser.

(Still on K-9 Mail 6.802 on the new Android 13 (soon 14), and 6.801 on the old mobile.)

Morning today, enabled Wi-Fi on the new (“not always working”) mobile, and let it be idle for some hour. (Didn’t do checks on PC e-mail client, since POP); needed to use something on the old (“working”) mobile and enabled Wi-Fi and immediately got a notification from K-9 about a couple of e-mails sent some hours ago (both mobiles has only one of the accounts set at periodic checks at the moment).

Went over to the new mobile and did a manual check and then it fetched the same e-mails, but it hadn’t fetched any during that time. As I said, it’s not reliable.

Addendum: just did another manual check for emails; spinning wheel for some time and nothing. Immediately went to settings and did the “test” as suggested in first reply above, i.e. went to settings for the Incoming Server and clicked Next and got:
check of Incoming Server settings failed; network error; details Connection reset.

That error is worth taking to the Internet provider. If they are good, they can pull logs from their side same time and see what they encountered.

If the VPN is disabled, do you still have these issues?

Short answer: yes.

I have now tested without VPN, over Wi-Fi. That doesn’t change a thing, and I had some other odd experience as well. (“Test”/save of incoming server settings worked, seconds before and after a manual check didn’t fetch a test mail waiting at the server … More below.)

Trying to find pattern in something that’s intermittent, well …

Am I right in that K-9, not using push, but periodically checks, set at say 15m, always should do an initial check as soon as a data link is enabled, i.e. when Wi-Fi or mobile data is enabled?

Test without VPN:
No Wi-Fi enabled on mobile; sent test mail from computer; enabled Wi-Fi, no auto check as soon as enabled. Started K-9, and did a manual check. It downloaded the test mail. Fine, but not perfect.

(Disabled Wi-Fi and cleaned cache on K-9.)

Sent another test mail from computer; enabled Wi-Fi, no auto check as soon as enabled. Waited 20 minutes, no periodic check (it’s set to 15 min). Checked settings for incoming server, it worked (i.e. “Next” gave “settings saved” and returned to settings). Did a manual check, nothing… Did another “check” of settings for incoming server, and it worked, again.

Enabled debug log, and did another refresh/check, nothing. That’s really odd.

So far I’ve compared with the old mobile (computer is downloading, POP), but this time I logged into my e-mail via web mail, haven’t done for years, and there it is, my latest test e-mail.

During this time I could do as many manual checks with K-9 as I wanted on the new mobile, with Wi-Fi and no VPN, but no fetch…

Enabled Wi-Fi (with VPN) on the old mobile, and then went to K-9 and the test mail was already there, but no notification, probably because it was already marked as read (as I did that via webmail).

As mentioned I haven’t yet talked with the service provider; that said, isn’t it just wonderful, everyone can point in another direction.

The email service provider could say: well, since you have working email in your computer’s e-mail client (and have been working for 10-15 years), and your old mobile works with the app (apart from, as I mentioned above, some weird timing issue/other when at times some mail sent to an alias didn’t get fetched during manual checks) there’s nothing we can do, or indeed need to do. (It’s also possible that I do get to talk to someone that can, as mentioned, pull out some logs, or give other info, which can be of help, or help eliminate possible causes.)

In this forum, and I really appreciate all replies and help/information offered, it’s possible to not only point at the email service provider but also Android, perhaps the latest security update, the (new) mobile (model), my VPN service, my Wi-Fi connection (but the last two, and service provider are at least the same for both mobiles, one working and one not all the time, as it seems).

And in the wonderful world of mobiles, usually there is no way to uninstall and install an old version of an app (unless you have used some kind of backup, or download and sideload etc. That adds another obstacle. That said, the first few days it (the installed version) seemed to work; but since no major outbreak of problems, error is most likely somewhere else, but no help to find.

There are a couple of errors experienced here (I do understand that, as mentioned above, if a manual check doesn’t work there’s no need to try to “fix” periodic checks, fix the first one first.) However, it’s intermittent. As we know certain errors can have a couple of different causes, depending on situation, and that seems to be the case with: “java.net.SocketException: Connection reset”.

Before I give up and blame everything on the new Motorola and get on with life without a mobile email solution (that works), I guess I could start doing another series of test without the case for the mobile, if there is any material/something there that interferes with the Wi-Fi signal, which is ridiculous (a quick speed test I did at some point showed full speed and low ping). Or do tests only on mobile data (in fact I finished my test above with enabling VPN again, and did a test over mobile data instead of Wi-Fi, but K-9 didn’t fetch the test mail. (And yes, btw, some have had problems with notifications for other messaging apps on this model, but in my case we are talking about a direct manual check, done less than 3 m from a Wi-Fi access point.)

And I also don’t believe in randomly changing this or that, enabling/allowing everything just because. As mentioned all battery saving settings are disabled, for all apps. For example, in Settings, for each app, there are settings for mobile data and Wi-Fi; one of them, mobile data in background, is usually allowed for most (and is for K-9 since nothing is changed), but the next setting, unlimited data use, isn’t enabled, and there is no need for that, since that one only applies if Data limitation is enabled under Settings > network and internet, and it isn’t. There are no data limitations, so no need to enable unlimited for K-9. In fact, apart from perhaps some system apps, usually there are only a couple of apps that have unlimited data use enabled (if data limitations should become enabled at some point).

I gave up and downloaded the last test mail on my computer. As it is now, I would be happy if could just get manual checks to work, all the time (as I used the old mobile some months ago before changing to periodic checks).

What was the last thing I saw on the new mobile before I called it a day? Wifi or mobile data is now disabled. A spinning wheel in the notification area, can’t believe my eyes, and if I look at K-9’s app icon on the home screen there is a dot (we usually see this when there are new mails, or as in this case a failed check that takes extra long time)…

What are you doing K-9? There’s no data link to use.