Cannot send an Email out of my Domain

I am the email admin for my domain via a arvixe server. K9 is setup as IMAP. K9 recives all email fine. If I send an email to my laptop, wifes iPhone, my Linux server, etc sending works fine. If I send a email to another Domain like my customers (usually school.gov accounts). I have tested with 3 differnet customers and they nver get my email. When I log into my cPanel and access my phone email account on the arvixe server I see the email in my sent folder as if it was sent, but the customer never recived it. As a test I made and sent an email (from Horde in cPanel) from my email address associated with my S22 Ultra. My customer gets the email. My conclusion from my cPanel test is that my email address is good as far as the server in the cloud is concerned, so the problem is with K9. WHat I have personally never seen before is a phone that actually sends the email to the server, but the server evidently has an issue with the email and it goes no further! Unless email is to a user in the same doamin then it works fine.
I have loaded every software update avilable for my Samsung S22 Ultra.

1 Like

Addtional information: K9 version 6.501
Phone: Galaxy S22 Ultra
Model SM-S908U
Android Version 13
One UI version 5.0
Android Security patch level January 1, 2023

on your S22 device what do you have for the following K9 settings on the account(s) where outgoing mail isn’t being delivered:

smtp server:
security:
port:
authentication [type]:

Outgoing server settings:
smtp server: shared101.arvixe.com
security: SSL / TLS
port: 465
authentication [type]: Normal Password

If I click NEXT at bottom of page, K9 likes and accepts these settings as valid.
If I send an email from my Galaxy S22 Ultra to my Desktop PC which bothe end in “southcomm.net” the the outgoing email goes out just fine and is received.
If I try to send an email to another domain, for example to you, then you never receive the email.

You could enable debug logging to see the commands and responses exchanged in the SMTP session. See LoggingErrors · thundernest/k-9 Wiki · GitHub

K-9 Mail only uploads the message to the Sent folder if the outgoing server has accepted the email for delivery. If it isn’t delivered to the recipient, it’s most likely a problem with your mail server, not K-9 Mail.

1 Like

The problem is NOT the server.
The only way I can fix my lack of sending a email problem is to delete K-9 mail and add another one. I added Edison Mail and it works with the arvixe email server just fine. As I said before, Thunderbird on 2 other PC’s works with my server. The problem is with K-9.
Any thoughts. Something unique with arvixe email server setup options? arvixe is using; DKIM, SPF, Reverse DNS (PTR) as email deiverability options enabled.

Previously I also delted and added back K-9 three different times trying to get it to work. Not interested in a seperate issue (unless it is related), but everytime I tried to install K-9 I found another problem which may be Sansung? I do not know. On intial setup on incoming server, if you type “shared.arvixe.com” , as soon as you hit the second “.” the NEXT button at the bottom of the page greys out. I finnaly fixured out that I could get it to work if I pressed the [.COM] button instead of typing .com out with 4 keypresses. I was astonished! If you wish I can have my wife video the failure and I can send it to you. I do admit these are crazy problems.

as @cketti showed in https://github.com/thundernest/k-9/issues/6578#issuecomment-1383051785 your message is getting delivered to your outbound relay mail server. why it isn’t reaching your recipient is something you’ll have to take up with your mail server admins. you should, at minimum, be getting a rejection if they (or the recipient’s server) is rejecting the message. you can ask your admins to look at their mail logs for the id that they assign the message on receipt from K9 – e.g., 250 OK id=1pGqpF-0038V7-BS in the dialog from your log.

perhaps related, there is an issue with your rDNS/PTR record. ideally 143.95.226.52 should point back to southcomm.net. instead it is pointing to ip-143-95-226-52.iplocal, which is basically bogus. whether your recipients’ sites reject mail because of this or not is a configuration decision on their side. regardless, if they do your server should be returning the error to you.

additionally, your 143.95.226.52 ipnumber is showing up on a couple of block lists. they weren’t major ones in my view, but the recipient hosts could be using them and handling your mail accordingly.

so, the first question (of your mail server admins) is whether your messages are being delivered to your recipients’ machines.

Addtional information: I have created a gmail email for myself just in the cloud for testing purposes.

Please expalin again because I do not understand the following: Why is it the server the problem if:
Samsung Galaxy S22 Ultra with outlook works ok.
Samsung Galaxy S22 Ultra with Edison Mail works ok.
Samsung Galaxy S22 Ultra with K-9 cannot send a message to any other domain. customers, gmail, etc

All the above have the same IMAP incomming and Outgoing settings.

Also my other company iPhones, , laptop, Desktop PC’s running Thunderbird have no issues

All the things you said are great ideas. I am my own arvixe email server admin. I can check a log or header, but sure looks likes only a K-9 client problem?

Open for any other ideas?

it’s a server problem because … once the message has been accepted by the mail server (as is shown in your logs) subsequent handling of the message is out of K9’s control. the server may be configured in a way to not like something about the message that K9 delivered to it, but once the server has accepted it the server should report that to you. that the messages appear to be disappearing is a problem, and it’s your mail server admins who can (read must) explain that to you. if they are silently tossing them they are operating the server well out of the range of “best practices”.

1 Like

I agree with your previous post. I think you are right on the spot by saying, “the server may be configured in a way to not like something about the message that K9 delivered to it”.

I can ony do 2 things:

  1. Does K-9 support have any suggestions of anything that I can toggle on or off to make this paticular IMAP server “like” and deliver the messages.
  2. or I can open a ticket with arvixe technical support, and have them look at a specific message header or something to see why it is not being delivered.

Going to be tough convincing arvixe tech support to work on th problem if I tell them 1 out out of 6 email client apps does not work with their sever?

I am a rank amater at advanced email admin, but if thier is a message header or someting you would want me to post I will try to provide and inforrmation you need. There are aslo email delivery options in the sever if you give me some things to turn on/off?

if you can check the server’s mail logs, then look for the id on the message that was delivered in the dialog previously discussed: id=1pGqpF-0038V7-BS. trace that all the way through and see what happened to it.

if you can’t check the server logs yourself, ask the system admins where that message went?

K9’s mail handling is very standards compliant. if your system’s admins are deviating from the standards it isn’t for K9 developers to try to guess what these deviations are and to make non-standards compliant changes to K9 to match up with whatever your admins have done. there are standards for a reason.

The same thing is happening on my S22ultra for the last week or so. As long as I’m sending within my ISP’s domain (bluehost.com) it works fine, but not to gmail, AT&T, etc. I can also send emails from several other mail client apps, but emails from K9 just disappear. They say they’re sent, but they don’t arrive.
I went to second level, server support with bluehost.com and they assured me that everything is fine on their end and tested several Windows mail clients to prove it.
I have removed the mail account in K9 and reinstated it but it didn’t help.

Thanks,

jbf

Arvixie, Bluehost, and Hostgator are all EIG brands. Hostgator has been confirmed to accept email from K-9 and silently discard it. I would expect all EIG servers to have the same configuration issue.

Yes I had the same problem. My webhosting company for my domain in the cloud is arvixe, and it is intersting to hear that you are having the same problem. Nothing personal against K-9 technical support, but, K-9 tech support responses are not satisfactory. For example: The strict compliance to standards answer I understand. My response is that since Thunderbird 102.6.1 (64 bit) works fine then K-9 needs to have the standards compliance degree of Thunderbird. (and all the other S22 android apps that work. I love Thunderbird and really want K-9 to work. My solution for the time being is to use Edison Mail since I run a business and cannot be down for another week.

I think that seeing K9’s standards compliance as the problem is looking at things the wrong way around. K9 is delivering the mail to your MSP’s server in a standards-compliant manner. In the case of your earlier logs, your logs have shown that your server has accepted the message. Having accepted the message, what your server should be doing is either delivering it to your non-local recipient or returning a bounce/reject to you.

That your MSP’s server is not doing that, and the mail seems to “disappears” (after the server has accepted it), is the [standards compliance] issue. If there’s a problem with the mail that K9 is generating your MSP’s server should reject (or bounce) it.

Once a message has been accepted by your server (and not rejected or bounced) it is out of K9’s hands and there is nothing further that K9 can do - K9 can only assume that your server is handling/delivering it. If your server rejected or bounced it then there would be something to go on, but your server silently dropping it is way off standards compliance and “best practices”.

As indicated previously, log the delivery handling of a message from K9 to your MSP’s server (as you did earlier). If it is successful, at the end your server gives an id, e.g., id=1pGqpF-0038V7-BS. If the message isn’t delivered to the recipient, then ask your server admins to trace that id in their mail logs. With the detailed logging information it will then be possible to discuss what the issue is who can fix what.

And a first step might be that rather than dropping them silently, your MSP’s server can start by rejecting or bouncing messages that it’s not willing to deliver, as is the standard.

3 Likes

I agree with your statements about standards, but the fact remains that when I send mail with other apps, including Samsung’s default app, it works.

1 Like

If, as was shown in @Shar-Pei’s logs, the message is accepted by the MSP’s server and it then “disappears” there is nothing that can be done on the K9 side until the reason the messages are dropped is identified. an even marginally compliant server will either reject a message (from an authenticated user) that it doesn’t plan on delivering or will send back a bounce. lacking any information on why the MSP’s server is dropping the messages there is really nothing that can be done on the K9 side.

so, if you have messages that aren’t being delivered to your intended recipients, start by logging the “send” exchange between K9 and your MSP’s server (see @cketti’s post above in this item for information on logging). if that log shows the message being accepted by the server, then ask your server’s admins to provide the reason (logging detail included) that the message has disappeared. many server’s provide an id on the final “250” on a successful exchange. if yours does, provide that to your server’s admins as that will help them to do the trace.