Android 10 Notification Issues

K-9 Mail does not provide notification, alerts, or dots count on my Android 10 tablet. It runs perfectly fine when opened, but does not appear to run in the background even with background permissions enabled Anyone else experiencing this issue?

Android 10 does seem to have many issues since rollout. I have turned off battery saver functions, allowed all permissions, and made sure notifications, dots, and alerts are enabled. Cleared cache and restarted device all to no avail. Any help is appreciated.

K-9 Mail version 5.600
Android: 10 (QP1A.190711.020 release-keys)
Locale: en_US
Model: onn 100003561
Product: 100003561 (mid8011)
Kernel: 4.9.190 (kanghua20051533)

1 Like

Hi,

5.600 is the most recent stable version but it is pretty old (released in Sep 2018). K-9 is currently being updated with support for Android 10 and a new user interface. If you want to try the new version, you can join the beta test on Google Play. The new version is missing push support but it has a reliable 15-minute update interval that should work fine on Android 10.

Thanks for the info ByteHamster. I will sign up for the beta.

Hi !

Well, I am in the beta program, installed V5.715.
Not any notification makes it to the notification area. I have 4 accounts and none of them have notifications. No status bar icon, no sound, while the settings seem to be OK, everything is activated. The only notification that works is the app icon badge.

One strange thing I noticed: In the system notification settings for K-9 Mail, it gives possibilities for all 4 active accounts, but at the bottom it says mysteriously: “1 category deleted”. I have no idea why, what that means or how to get that category back.

Finally; I use K-9 since the very first Galaxy and experienced never any problem with this. I used the last stable version 5.600 without problems. The moment I subscribed to the beta program (I think the first version I installed over the stable one was 5.712) I lost the notifications area.

Version K-9: 5.715
Version Android: 10, all latest updates installed
Hardware: Galaxy S10

Hi Lupercus

Not getting notifications for new emails can have a couple of reasons. You have already ruled out some of these, but I’m listing them here anyway so others who are in a similar situation will have a hopefully complete list to check against.

  1. Automatic sync is disabled. If K-9 Mail isn’t checking for new messages not getting any notifications is to be expected. Make sure ‘Account settings > Fetching mail > Folder poll frequency’ is set to something other than ‘Never’. Also, ‘General settings > Network > Background sync’ controls in which situations automatic sync is allowed.

  2. Notifications are disabled in K-9 Mail. Make sure ‘Account settings > Notifications > New mail notifications’ is checked. If you’re testing notifications by sending a message to yourself, make sure to also check ‘Include outgoing mail’. Otherwise new messages with your email address as sender address will not trigger a notification.

  3. Notifications are skipped because of K-9 Mail’s Quiet Time setting. Check under ‘General settings > Notifications > Quiet Time’.

  4. Notifications are disabled via the system’s notification configuration. On modern Android versions users can disable notifications, change the alert sound, and many more things. You can get to the system screen to configure notification via ‘Account settings > Notifications > Notification settings’.

  5. Notifications are disabled because the system’s ‘Do No Disturb’ mode is active. (On modern Android versions) users can configure notifications to override the DND mode. How DND mode is enabled and disabled depends on the Android version you’re using.

  6. Notifications are being generated, but messages are marked as read on the server. When this is detected by K-9 Mail the notification for that message is removed. This is done because messages that are marked as read are not considered to be a new message.

  7. The app is killed with active notifications (maybe because the system is running low on memory). Then it is restarted and generates a new notification. This new notification will cause all old notifications to be lost. This is a bug in K-9 Mail that we intend to fix soon.

  8. There’s an unknown bug in the app. If you can rule out all of the above, it’s probably a bug we don’t know about yet :frowning_face:

I hope this list helps you to track down the problem.

1 Like

Hi cketti

Thanks for the extensive and prompt answer, much appreciated!
I answer you point by point.

  1. folder poll frequency is 15 minutes, background sync is “when auto-sync” is checked. That works fine anyway, the messages keep coming in during the day. Plus, all thise new messages are marked as unread in K-9 when retrieved.

  2. new mail notifications are enabled, and now I also checked include outgoing mail. Sent a message, still no notification.

  3. quiet time is off.

  4. system’s notifications configurations: all are on, with sound. Except for that one mysterious “1 category deleted” at the bottom, still no idea what that might be.

  5. Do Not Disturb mode is indeed on during the night, but the problem is there also during daytime

  6. Interesting feature … but no, the messages on the server are still unread when they are retrieved. Could it be that K-9 Mail marks them read BEFORE retrieving?

  7. Could not say, bit hardly thinkable. This is a brand new Galaxy S10, no other app has this problem … in view of this possibility, have to say though there is ONE notification that comes through: the app icon badge, and then ONLY when actively the messages are retrieved.

  8. OMG :slight_smile:

So … everything seems to be set the way it should be, but still no notifications …
Just let me end positively by saying that I still do enjoy K-( Mail, even after I think something like 7 years heavy usage !

That’s probably because you enabled sync notifications. During that time you should also see an animated notification icon in the status bar.

I’ve had a look at the code and there are a couple more conditions that have to be met for a new message notification to be created.

  • The folder must be displayed in the folder list. Check ‘Folder display class’ under ‘Manage folders > [Your folder]’.
  • The folder must be included in what is configured under ‘Account settings > Notifications > Notifications folder’. Either set this to ‘All’ or make sure the folder has an appropriate value under ‘Manage folder > [Your folder] > Folder notification class’.
  • The message must not be in one of the following special folders: Trash, Drafts, Spam, Sent
  • If ‘Account settings > Notifications > Contacts only’ is checked, notifications are only created if the sender address matches one of your contacts in the system’s address book.

Hi cketti
Again, I thank you for dealing with this, it is much appreciated.

Sync Notification: yes that is on, and you are correct: in the notification area is this animation during the actual syncing.

Folder list: for instance the inbox, where about 95% of all mails end up in, is marked 1st class, as well in the folder display class as in folder notification class. Under “folders to display”, the option that is activated is “all except 2nd class folders”. So that should be OK.

Special folders: the new mail arrives normally in the inbox, so not in any of the special folders.

Contacts only is not checked. (nice option though :slight_smile:

Sorry, would have loved it if one of your suggestions would have made the difference!

@Lupercus: Thanks for checking. Unfortunately, the current version doesn’t contain enough logging to be able to track down the issue that way. I’ll try to add that for the next version.

@cketti: thanks, I’ll get that via Google’s PlayI assume.

Received a new version today… @cketti, should I debug with this version, and should I mail that to you, or place it here?
Thanks for all your good work!

Yes, the new version contains logging with information on why a notification was or was not created. Please follow these instructions: https://github.com/k9mail/k-9/wiki/LoggingErrors

1 Like

OK, problem is solved. Great!

It was caused by having the “sent” folder configured so that it placed sent emails in the InBox, something that was up until V5.600 possible without losing the notifications.
Please see https://github.com/k9mail/k-9/issues/4820#issuecomment-639163502.

1 Like