No notification sound and vibration after upgrading from Android 13 to 14 on Xiaomi

Xiaomi Redmi Note 12, Xiaomi HyperOS (Android 14)
K-9 Mail 6.603
Gmail Account

Hi all,

I am using K-9 Mail since a couple of years, thx for this awesome piece of software, but now I have an issue which I cannot solve:
since upgrading from Android 13 to Android 14 I don’t get any notification sound and vibration tone anymore.
The push notification in the status bar arrives, but no sound, no vibration.

I reinstalled K-9 Mail, default settings, just added my Gmail account, same issue. I reinstalled again and imported my working k9s settings from Android 13: still same issue.

Other apps with push notifications are working fine, though: Signal, Telegram, Pushover, …

Taking a look at the debug logs it shows:

01-04 21:10:34.672   352   441 V ImapSync$downloadSmallMessages: About to notify listeners that we got a new small message Gmail:INBOX:110200
01-04 21:10:34.677   352   441 V NotificationController: Creating notification for message c206ed1e-6eea-4682-bb19-503fdb27f553:2:110200
01-04 21:10:34.682   352   441 V LockableDatabase: LockableDatabase: Transaction ended, took 2 ms /
01-04 21:10:34.814   352   441 V SingleMessageNotificationCreator: Creating single summary notification (silent=false): Notification(channel=messages_channel_c206ed1e-6eea-4682-bb19-503fdb27f553_1704220867 shortcut=null contentView=null vibrate=null sound=null tick defaults=0x0 flags=0x200 color=0xff0099cc category=email groupKey=newMailNotifications-0 actions=2 vis=PRIVATE)
01-04 21:10:34.824   352   441 V RealImapConnection: conn43535902<<<#135# [OK, Success]
01-04 21:10:34.825   352   441 D ImapSync: SYNC: Done fetching small messages for folder INBOX

vibrate=null sound=null is strange as I have set a sound and also the vibration option.

I already checked everything in this post but was not successful

Any further hints what to do?

Update: I resetted the phone and installed everything from scratch, still no sound.
I expect now a bug in K-9 and will open a github issue.

Updating to K-9 Mail version 6.714 solved the issue, sorry for the noise.

1 Like