Account in office 365 doesn't work on k9

I have a problem with email account in office 365. My account isn’t working now in k9. It has stopped since yesterday

Welcome!
Please describe in detail what is not working anymore.

When i try to test the account it got a message “wrong user name or password” and "Authentication unsuccesful, basic authentication is disabled.

When I configure my accoutn in outlook or bluemail ewerything is good

Did you read through this?

2 Likes

I did create an app password in O365 but have the same issue in K-9.
Checked many times with different passwords - the same result. Any ideas?

Thanks

What, specifically, is the error that (I assume) you are getting?

What mail service provider are you trying to connect to?

What settings are you using for your incoming and outgoing server setups?

Also, please give the android release on your mobile device and your K9 version.

Hi,

Android version 12. Email account is at O365, works on outlook and web. Two factors auth, made app password twice, none worked out.

Settings:
Outlook.office365.com
Ssl/tls
993

and error attached.
Thanks a lot.

I get the Same Error with my office365 Account.
At Others Mailers ist works and yes the Name and Passwort are right. I dident have the MFA enabled.

I have the same problems. My mail provider just switched to O365 and I now need OAuth2 authentication and k-9 does not have it.

I fear I/we will all need to abandon k-9!!

Leo

Hello Forum, I just registered as a new user, based in DE.
My problem is not exactly the one described above, but it fits well under the thread’s subj.

Switched to office365 (exchange online) last week. Works nice in all Outlooks around, not in K9. IMAP is fine, mails are being received. Mails to be sent are stuck in outbox however. SMTP settings so far are ok: once entered sever/login/port/etcetc K9 performs a test, no issues, it just closes the window. Entered a wrong password by purpose, then K9 drops an error. SMTP has been enabled in exchange online for the account under question. Anyway mails don’t leave.
Hoping for help of the forum. THANKS!!

edit: I moved such a mail from OUTBOX to DRAFTS. Then I klicked ‘send’. And the mail had been sent! Look like a bug in K9, not as an SMTP issue.

Nah, not K-9 but silly behaviour on the Exchange Server. The way outgoing mails are handled depends not on you MTA entirely, but in large chunks on the way you communicate with them. Here, M$ has a naming scheme that you need to manually set in K-9.

As a workaround, in the account’s settings you can change the outgoing folder to drafts.

Hi tchara, thanks for reply! Forgive me… I cannot find any setting where to change folder name in K9. There are setting which existing forder I want to use for drafts/sent/deleted/spam, but nothing to rename one.
And frankly speaking, I did not understand yr meaning ‘naming scheme to be manually set in K9’.

Hi!
Unable to login with imap and office 365 either. Created an app-password but the response is always:

(Command: *sensitive*; response: #3# [NO, LOGIN failed.])

You need to provide more details for people to try to help you:

  • receiving (imap?)/sending
    – server settings:
    • server name
    • security
    • port
    • authentication [type]

Hello, same problem than @ruapho here (same error message). I had an app password working for several years, this just stopped working yesterday, without any config change in my client setup or our Office365 tenant Exchange setup.
The problem is only (for now …) with the incoming email server (IMAP), SMTP is working fine. IMAP config:

  • IMAP server: outlook.office365.com
  • Security: SSL/TLS
  • Port: 993
  • Authentication type: standard password (no encryption)

I read that Microsoft will eventually drop support for Basic auth IMAP login, and will support only IMAP with OAuth 2.0. But this shall only be enforced in October 2022.

Thus:

  • I don’t know if the problem is related to Microsoft dropping support of IMAP with basic auth
  • When the IMAP basic auth support will be gone, will K-9 mail support OAuth 2.0 or will I have to use another client to access my O365 mailbox?

This is what I assume that will be implemented in 6.200