Yet another Gmail setup failure issue

Hello, another K-9 mail newbie here and I seem to be having all sorts of problems getting K-9 Mail to set up and configure itself for email accounts. I have an old faithful Samsung Galaxy S-8 phone and I have installed the K-9 email app on it. I have search the mail threads here and via Google for information about this problem. I am currently trying to set up K-9 Mail for a Gmail account I have. (yes I have read through many many postings that other users have had with Gmail, but found nothing apropos.

Following the guide at How do I add a Gmail account? I can’t even get past step 2. When I try to sign in with Google, by clicking on the button for doing so, (which BTW is just a white button, with no words or display of any kind, perhaps using white characters against a white background?) the app then asks me if I want to open another app and leave Firefox to view this content? I click on open and get a message with a spinning circle saying “Checking incoming server settings” It spins for a few minutes and then says “Setup could not finish” and “Cannot connect to server.”

I have tried the manual setup approach also, setting the IMAP server to, Security to SSL/TLS, Port to 993, setting my user name, Authentication to OAuth 2.0, checking the Auto-detect IMAP namespace, and checking the Use compression. I don’t grok what it wants for the IMAP path prefix text box, so I leave it blank. When I click on Next, it goes to the same message I described above, “Checking incoming server settings” and that is as far as I get, same failure message as described above.

So I am lost and don’t know how to find joy getting an account set up for my Gmail account! Any gurus around who can guide me out of these woods? Much appreciate and thanks in advance for any ideas!


P.S. I will start another thread soon about a different problem I am having setting up K-9 Mail with accounts on my own Apache James email server, but it is late now and I am going to bed a bit frustrated!

Ping! Are there no gurus around willing to lead me out of this deep dark mess I have gotten myself in? I continue to flog away searching the internet for a solution but still no joy finding one! Please help this poor lost soul!


By chance, and I hope so, do you have 2FA set up for your Google account? Either TOTP, or a prompt on an Android device?

You may want to set Chrome as your default browser and try step 2 again. Rather than Firefox.

If that fails…

I’ve been using a Google App Password for years on my k9 against gmail. Somewhere in your Google account security settings you may be able to find it. It’s a code generated by Google, maybe 16-24 chars long, and is used as the password to your account.

Yes, according to my Google account, 2-Step-Verification is turned on and it is set to prompt me on my Android cell phone. I wonder if perhaps because I am trying to set up my K-9 app, on my cell phone, there is a problem with Google’s ability to prompt me on the same cell phone?

I can give Chrome a try, but I don’t want it as my default browser. I use Firefox to access a telescope control website, a lot, and that website does not work under Chrome.

I will look into getting a Google App Password and let you know if it works.
Thanks a million for your suggestions, and I appreciate the time you took to write me! I will get back to you soon with the results… Marc…

Try recording a debug log to get more information on what’s going wrong. See LoggingErrors · thundernest/k-9 Wiki · GitHub

Thanks cketti for your suggestion, I managed to get a log and transfer it from my phone to my desktop computer. But I don’t know how to get it to you, this web based interface does not seem to have an option for attaching a file. Do you want me to post all the text from the log file here, it is rather lengthy! Or do you have a better idea?


What about opening an issue at GitHub?

Thanks Tchara, since no one else has responded, I will follow your suggestion and open up an issue at GitHub…


cketti already has responded that you need to post the logs. Without the logs, posting your problem in a different place won’t change anything.

1 Like