Settings Export Fails in v6.600

Hello Everyone,

Just updated to version 6.600 and noticed that settings export fails.

It only seems to save a partial file, in my case about 8k whereas the settings file is normally about 18k.

Anyone else experience this?



Can you compare old and new settings files and let us know what is missing in the new file?

Thanks @cketti Will get you that information later today

Hi @cketti,

I did a diff and it looks like the Identities section is missing (I have a fair number defined) and strangely the Folders section is missing (I don’t think I’ve done anything unusual there, though I’ve added/renamed some).

Thanks, by the way, for all you do for this project.


@cketti exports are still failing in 6.601

I haven’t backed my settings up in ages so I just tried it and the backup was saved without any error message and looks to be the correct size too.
5 email accounts with all the settings backed up, to a custom folder inside my Backup folder on the device. Rooted OP 8P OOS 11 k-9 6.601.

Thanks @Nimueh

Would it be possible for you to create one or two additional identities and then try the backup again? Additional identities along with whatever changes I made to rename folders seems to be what is causing the backup to fail

I’m not sure what you mean by identities - more email accounts? If so then no, those are the only ones I have :woman_shrugging:

If you go to Settings, then pick one of your accounts, then go to Sending Mail, you’ll see a section called Manage Identities.

That section (along with the Folders section, at least for me) is what’s no longer being backed up in 6.600+

1 Like

Oh I wouldn’t know what to do there, nor do I change the default folders since I store all my emails in my PC client, along with dozens of custom folders.

I’m afraid someone else will have to test that for you, sorry :woman_shrugging:

Okay no problem thanks very much for responding

1 Like

Just tested with 6.601 - both identities and folders section available in my export.

Hmmm OK thanks @stphn

It looks like my export file is getting truncated. It seems to be exactly 8K (8192 bytes) per FX (unless that’s just the way Android allocates its blocks).

The last few lines are:

<value key="autoExpandFolderName">INBOX</value>
        <value key="archiveFolderName">Archive</value>
        <value key="draftsFolderName">Drafts</value>
        <value key="sentFolderName">Sent</value>
        <value key="spamFolderName">Junk</value>

It ends after the word “value” so that section isn’t even all there.

@stphn is your backup larger than 8K? Previous to 6.600 mine were about 18K.

Thanks very much for helping with this.

Have you tried revoking and re-granting file permissions to K-9? Clear the cache in-between.

Also tested with full export - yes, more than 8k.

But I remember that when I moved to my new phone a few weeks back then I had a truncated export file as well. And yes, it is 8.194 bytes (just checked). At that time I could only export when I deselected my main account - which was the only with several identities.

If I find time I can check on old phone which k9 version it was (most probably some 6.50x) and if is related to identities.

1 Like

Unfortunately, we currently don’t log the error that causes export to fail. The logging code will be included in the next beta version. That should make it easier to track down what is causing this error.

@tchara thanks for that suggestion. I don’t think I’ve looked at K-9 permissions before. File permissions don’t seem to be an option, which seems odd. Here’s a screenshot:

@stphn thanks very much for confirming that it’s not just me. Did the problem just resolve itself or did you have to take further actions?

@cketti thanks very much for adding the logging code. That will definitely help.

I just tested on my old phone: it failed with 6.510 and also after upgrading to 6.601. It fails with my single account which has several identities. The others have only the standard identity and export worked fine for them. Hence I just exported and imported those and had recreated that single account manually on my new phone.

1 Like

There’s a bug where export fails if you have an identity without a sender name configured. A fix will be included in the next beta version and once it’s been tested the fix will be included in K-9 Mail 6.602.