Sending Mail Stopped Working

I’m successfully able to receive new emails but not able to send.

Error message: "Cannot connect to server. (Unable to open connection to SMTP server.)

In my troubleshooting, I performed a fresh install of K9 on a different device, but the same unable to connect to outgoing mail server resulted. The saved password is correct due the fact authentication is successful to incoming mail server and successfully receiving new emails. Incoming and outgoing passwords are the same in O365. My sending email server configuration is below.

Outgoing server settings:
SMTP server =
Security = STARTTLS
Port = 587
Require sign-in = checked yes
Username =
Authentication = OAuth 2.0

“Cannot connect to server” means just that. Your device is not able to connect to the remote server.

The server name is correct and works for me. That leaves a network error as likely source of the problem. If I had to guess, I’d say it’s IPv6-related. The fallback to IPv4 isn’t working properly in the current stable version of K-9 Mail (6.202). Try using the latest beta version. See How do I become a beta tester?

I have the same entries and it works correct.


I cannot send mail anymore from my android smartphone.
If I test output settings I get this message: UNABLE TO OPEN CONNECTION TO SMTP SERVER.

My account uses port 25 and no encryption.
SMTP Settings on my provider did not change and I am still using the same mail from outlook on computer with same settings and I can both send and receive.

May I provide other details to help you check the issue and to fix it?

Thank you

are you using the same connectivity for your mobile device as you are for your computer? if not, it’s likely that your mobile device’s connectivity provider changed, (removed), the ability to send on port 25. most consumer-grade connectivity providers stop considering open outbound port 25 to be part of “best practices” ~15+ years ago.

you may want to check your mail provider’s current settings information to see if they accept inbound mail on either of the standard mail submission ports - 465 and 587.

in order to help further we’ll need the following:

Outgoing server settings:
SMTP server
Require sign-in?