On pixel device can't add gmail accounts without adding to device

Hello, I’m trying to transfer my emails to a new phone, but when I try to reauthenticate I get stuck.

I tried following this:

but, at step 3 it auto redirects me to add a new account to the device which I do not want.

This is with Chrome, with Brave I do see the rest of the steps, but at step 5 instead of k9 finishing the setup, I get a generic google home page.

Is there a way to finish this correctly?

My understanding of the new Gmail OAuth procedure is that that our does require the account be added to the device. You would need to use an app password and the “less safe apps” setting (or whatever it is called).

While I have a Gmail account that really has no other need to be an on device account, I opted to add it, as K-9 Mail was the only reason I still had app passwords and “less safe apps” enabled on any Google accounts.

1 Like

If that’s the case, how does my old phone still work with the old method? I think it’s something broken in the hook of the OAuth on K9’s side.

The old method was app passwords. As far as I know that still works. I changed my accounts to the OAuth method so that I could retire the app passwords and disable “less secure apps”.

If there is another way that uses OAuth without adding the account to the device itself, I am unaware of it. I am definitely interested in learning about such an option if it exists.

1 Like

I can confirm that this is a new issue on my pixel device.

I am no longer able to modify my fetching mail server configuration and update the App Password that was being used, as I am now forced to the Add Google Account to this Device screen, which is not something I am able or willing to do.

Sadly, this will mean the end of k9 updates for me and I will downgrade until this is resolved.

That has not been the case for over a year now. I moved to K9 when OAuth was introduced.

Which version worked for you? I just moved to my pixel and I want to set this up asap, even if means not updating k9 until this is resolved.

Interesting. I just removed my secondary Google account from my device and the Gmail is still working in K9. I know that doesn’t probably help you, but I didn’t know that was an option, so thanks.

No problem, now you know why this bug is so annoying for me.

1 Like

You said it is a new phone. Have you by any chance accidentally tapped on “[try/use/activate] enhanced security” when initially setting up the Pixel device?

If “yes,” you cannot access your Google account (or parts thereof, such as Gmail) without having the corresponding account attached and activated on your device. The setup MUST be completed through Chrome for some reason.

You can check in your account if you have enhanced security active. Alternatively, you can try installing an app from an APK/AAB file or from F-Droid. If installation is refused due to enhance security (not due to untrusted source! I literally mean due to enhanced security), the enhanced security is active on your account. You can only install “safe” apps from Play Store (even from there some apps will be blocked from installing).

You can deactivate enhanced security in your account. It will take roughly 24 hours to synchronise through all Google services.

I do not see such an option anywhere on my phone, however, I did install apps from f-droid and from an APK.

did you mean:

If you can install apps from other sources you don’t have it activated. - I meant Get Google's strongest account security with the Advanced Protection Program - Android - Google Account Help

OK so now we have established it’s not that, is this a bug? Should I open an issue on GitHub?

1 Like

Just tested it now, and it works for 2 of 3 of my addresses. The last one says it requires an app password.

That last one was my mistake, it stayed on normal password instead of OAuth. Once that was changed, all 3 worked.

1 Like