No incoming mail on new phone

I’ve just changed my phone from a Samsung Galaxy A3 to an A33 running Android 12. I used Samsung Smart Switch to copy all programmes & settings from the old phone to the new one. I also exported the K-9 settings from my old phone & imported them in the new phone.

I am not receiving mail. If I look in K-9 settings, account name, fetching mail, incoming mail, next, it will check incoming server settings then time out saying it cannot connect to server. It does this even if I have the phone connected to my web mail inbox. The web mail is Yahoo.

Can anyone suggest what else I should check?

I believe that on Yahoo you need to enable IMAP somewhere in Yahoo’s settings in order ti make the account accessible for k9

Gunter, thanks for your reply. The mail account is pop3 & it was working OK 2 days ago on the old phone.

Was you old phone configured to leave messages on the server? Normally, once POP collects a mail, it is removed from the MTA.

Thus, you cannot download messages that were downloaded by another client, unless you explicitly configure your MUA to leave a copy on the server.

Tchara, yes, that was why I chose K-9. It was the only mail client I could find that would let me choose not to delete from the server.

So, on Yahoo web interface you still see the old mails you already received with K9 on old phone. And you see new mails you got after you switched phones.

And both kind of mails you do not receive with K9 on new phone.

Which version of K9 do you use?
Was it the same on old and new phone?
Could you send screenshots of “Fetching mail” settings?
Could you please send a debug log?

stphn, yes I still see new mail on the old phone & nothing on the new phone. I tried uninstalling K-9 & reinstalling but it’s still the same. The new phone still can’t connect when I it tries to check the incoming server settings. I compared the settings with the phones side by side to make sure they were the same. I was wrong about the account type, it is imap not pop3.
Screenshots attached, struggling with the log as it will not let me upload a .txt file.

May I suggest you remove the screenshot that contains your email and upload it again after editing out the email? There are weird people on the internet, so better safe than sorry.

under “settings/[account]/fetching mail/incoming mail server settings”

what are the settings of:

  • imap server
  • security
  • port
  • authentication

additional notes:

  • imported K-9 settings do not include passwords, so you would need to have set that. i would think that, assuming the above settings are correct, that you should get an explicit authentication failure message on “Next”.

  • i believe that yahoo mail now requires use of either an app password or Oauth 2, so if you used your site-wide password (e.g., the one you use to log into your webmail account) in your setup that is likely to fail.

imap =
security = SSL/TLS
port = 993
authentification = Normal password.

I have used the password I use to log into Yahoo web mail, I can log in on this phone OK. I don’t have any other password.

and at the top of the “incoming server settings” screen (above the hostname line) it has “IMAP server”, (not “POP”) correct? there seemed to be some confusion early on as to whether your account was imap or pop. these are not interchangeable and so you won’t be successful simply putting imap settings in on an account that was initially set up as pop (and vise versa).

assuming that’s the case … when you select “next” what (fairly precisely) is the error message that you get when you say it won’t connect?

you can find the instructions for setting up an app password at:

about 2/3 of the way down in the android section, though they seem to indicate that your pw should work. yahoo is making the change so it may be good to set up/use an app password.

their documentation shows the imap host as “” rather than just “”, but they seem to resolve to the same ipnumber so it may not matter (unless they are using SNI).

It was me that was confused, Thunderbird on my PC is setup as pop3 but K-9 on my phone is imap.
When I select next it says " Checking incoming server settings…" then, after a minute or two it says "Setup could not finish, cannot connect to server (unable to connect). I select "continue & it reverts to the fetching mail page.

SUCCESS. The Yahoo app password did it.

Thanks to everyone for your help.

1 Like

Great! I would be nice if you could mark the helping comment as “Solution”. Thanks

It’s me again, I’ve realised today that K-9 is not sending mail, same scenario, when I look at ‘settings-account-sending mail-outgoing server’, I get the same can’t connect message as before. I tried creating an app password as before but that has not worked. Any suggestions?

It might just be my Jonah touch, my brand new work PC, installed last week, went into meltdown today with a blue screen of death loop. Happy days.

You need to set the same app password for outgoing that you did for incoming server.

what are your outgoing server settings?

  • smtp server [name]
  • security
  • port
  • require sign-in
  • authentication [type]

i continue to be curious as to why you seem to get “can’t connect” responses for what appear to be authentication issues.