Cannot add custom domain to oauth2

I am experiencing the same issue as this thread Cannot get OAuth2 to work with Gmail but the proposed solution does not work. Even when fully disabling the option in the solution, it will still open that same page, blocking me from authenticating. The whole reason I am using k-9 mail is that I wish to have a work mail account that is completely separate from my phone’s ‘accounts’