5.8 update installation crashes

Hi, I tried to update my K-9 mail client (5.6) which I use for a looking time and like it. Unfortunately during the 5.8 update installation from GP the phone freezes and reboots. Does anybody have the same experience?
My device: Redmi Note 8T, Android 10, MIUI 12.0.3 stable

At least one person had a similar experience when trying to update a version installed from F-Droid via Google Play. That doesn’t work because the version on Google Play is signed by the K-9 Mail project and the one on F-Droid is signed by F-Droid.
However, trying to install an app should never freeze or crash the phone. If that happens it’s a bug in the OS. You should report this to your device vendor.

OK, thx. Will try to reinstall the whole app and provide a feedback.

I’m seeing the same issue.

Model: “Moto G Play (2021)”
Android version 10
K9 was installed via a restore from google backup when I bought this phone. It did not come from F-Droid.

Would there be any kind of log I can get to?

Same here. Nokia 7plus, Android 10.
First time ever that already an installation / upgrade process in play store crashes the phone.
App was installed about two years ago from play store.
Will try uninstall and fresh installation.

1 Like

Can confirm for: Nokia 6.1 Android 10.
Version 5.600 installed from playstore.
Phone crashes & reboots during upgrade of K9.
Fingerprint sensor is disabled after crash, all entries are missing or unusable - never seen that happening before

[EDIT: Backup setting - remove 5.600 - restart phone - install 5.800 from Playstore - working!]

Can you let us know the result after fresh installation? I am in the same situation as you. K-9 was installed from GP a year ago (not FDroid).

Also confirming on two devices.

Nokia 7.1, Android 10
Lenovo Tab M10 FHD Plus, Android 10

Both installed with K-9 5.6 from Google Play Store.

Can confirm

Moto G8 Plus
Android 10

Install from Google Play Store

Same on my Xiaomi mi 9t.
The o.s. is Miui 12.0.5, K-9 Mail version 5.600 installed from google play store
The phone freeze and reboot after some seconds trying installation.

It already does seem like a device vendor problem. It seems more like there is something wrong in the update package on GP. Unfortunately I have not had a time to try it yet. May be this evening…
Has anybody already tried a 5.8 fresh installation from GP?

Fresh installation works on a…Android 7 :smirk:

Me too, same device and versions. (Nokia 7 plus, Android 10)

1 Like

I can confirm this on my ZTE Axon 9 Pro

  • up to date standard system
  • standard store
  • 2 IMAP Mailboxes
  • No other installations or upgrades have problems

It’s rather unlikely that we will find out what causes the freezes/crashes you’re experiencing. The app itself is not running when the system is installing the new APK. So it’s not something the app is actively doing. It’s more likely something in the app’s manifest that has changed and that some part of your system doesn’t properly handle.

Uninstalling and reinstalling the app most likely avoids this error. First, you probably want to export your settings. Go to the Accounts screen, then select Settings Import & Export > Export settings and accounts from the menu. After installing the new version you’ll be able to import settings in the first screen.

1 Like

This is an annoying workaround but it works.

Make sure you have your passwords at hand as they are not part of the export.

I confirm uninstall and fresh installation is a solution.

1 Like

Regardless, the user experience is poor, this will drive some users away.
I’ve now used the workaround myself, fine for tech savvy users maybe, but “it doesn’t happen on my device so it’s fine” can’t be where this gets left.

1 Like

I’ve had the same issue on Oppo Reno 4, Android 10, K9 installed from F-Droid. Installation progress bar freeze the entire device, after which it crashes and reboots automatically.

Same here. Can’t upgrade on redmi note 8 pro.
Android 10 crash and restart.
Must disable automatic update for k9mail :persevere: