Why drafts are never saved?

I don’t like the new interface of actual k9, folder management (cleaning up of local messages) is too burdensome while draft as ever get completely deleted moving to another app to copy and past or if momentarily abandoning k9. This issue has never been solved and knowing that I am always forced to copy text and infos to gtasks first, then select all and paste into k9. Any chance to look into it?

I am not sure if I understand this correctly. If you write a mail and change app or move out of compose mode the already written text is not saved as draft for you?
I just checked - works fine for me. I am using version 5.806.

Is this your use case or are you doing something different?
Also, is the Drafts folder associated correctly?

You perfectly understood. Sometimes it worked but most of times not. It’s really disappointing cause I lose most of my work if I forget to use a third party app to copy and paste momentarily. How can I find out if, as you say, the folder is corretly associated?
Thanks for your kind reply

Look at Settings / < account > / Folders / Drafts folder. Is there the correct folder set?


You made my day! You great! Thank you so much, I checked and it was not selected. I hope now the issue will be solved forever. Thank you so much for your patience. K9 is my most important and beloved app, I have been using it for years and years!

1 Like

My drafts do save but the formatting gets changed if I reopen a draft email. There are extra carriage returns scattered throughout that must be removed. Do you have this too?

Sincerely speaking I never noticed this behaviour.