Unable to grant permission on outlook.com

I try to setup my outllook.com account, but I can’t grant permission for K-9. A message popup and say that the page “msauth://com.fsck.k9/Dx8yUsuhyU3dYYba1aA16Wxu5eM%3D?code=M.R3_BL2.65654b7e-994b-b10c-fe7f-36f79473a9e0&state=EK7lee5tASldCIVIjISfkg” seem to be deffinitivly moved or encountering problems.

Here are some screenshots

Sorry it’s in french.

1 - First I fill my account details.
2 - Then I log in to Microsoft.
3 - When I click to grant permission for K-9 the following message appears.

anybody to help me ?

Did you follow these steps?

If yes and it still fails maybe you can post a debug log here.

1 Like

In case you have multiple web browsers, try using another one. Chrome and Firefox should work.



Yes I already follow steps in topic “How do I add an Office365 account?”, but still not works.

Here is a log :

(to many characters to post here)

Thanks for your support.

I already try FireFox, Brave, Edge but still the same issue

Thanks for your support.

From the log it looks like you’re using the mail app by the e foundation, not K-9 Mail. Please contact them for support.


Ok I will do


Do they have their own mail app? In logs I can see k9 related info - but maybe they have forked it? But then I would assume they need to make their code publicly available as well…

But maybe getting off-topic

They forked it and apparently did not make it clear enough that their fork is no longer K-9 e / os / Mail · GitLab

Thanks - I searched here e Foundation · GitHub and there was only a webmail browser extension.

/e/ 's code is hosted on their own gitlb instance https://gitlab.e.foundation/e

The fork of K-9 is at e / os / Mail · GitLab

If you want to discuss the problem you raised, the /e/ Community support forums are here or you can create a gitlab issue here