Switching to OAuth in K-9 6.100

How do I go about switching from an app password to OAuth?

I just tried simply replacing the app password with my regular one and got the error from the screenshot, saying that an app password is required.

How do I get out of this now, what are the steps to use regular old (well in K-9’s case, NEW) OAuth?

1 Like

Currently you have to manually update your existing accounts. Go to Settings → [Account] → Fetching mail → Incoming server , select OAuth 2.0 under Authentication , then press the Next button. Same under Settings → [Account] → Sending mail → Outgoing server.


Thank you, that worked like a charm :slightly_smiling_face:

Sorry, for authentification, I get three options:

  • Normal password
  • Encrypted password
  • Client certificate

Does any of these correspond to OAuth 2.0?

Thanx in advance

No the one for OAuth 2.0 is called “OAuth 2.0” :smiley:

The option is only available for IMAP accounts. And for now it’ll only work with Gmail, Yahoo, and AOL accounts.

1 Like

I have an imap accout from office365. Would be nice to be able to further use it.

We’re currently waiting on Microsoft. See Add OAuth support for Microsoft accounts by cketti · Pull Request #6115 · thundernest/k-9 · GitHub

1 Like

The “OAuth 2.0” option shows, even with an M$-type of account, you just get a message that it’s not available yet when you try to set it up (don’t remember the exact message off hand). This is only available with K9 6.1, so if you’re only seeing the three authentication options you list I suspect you are using a release lower than that.


I cannot follow this one; but I see you are after it.

Perhabs this helps: I have also the onecalendar app on my mobile. Some weeks ago, they required from me, that I delete my account and re-registrate it. They mentioned a microsoft issue; possibly the same we have now. And apparently they found a way, because after I did this, everything worked fine again.

You are right; i have 6.0. So, I de-installed and reinstalled, but i still got 6.0 But if it does not work; there is no sense to put it into the App Store.

Why de-install? Simply update from 6.0 by installing 6.1 which you can find on github.

I updated mine from 6 to 6.1 shortly before starting this thread here and it works just fine.

1 Like

… but if you’re using an office365 account (and don’t have a gmail/aol/yahoo one) you might hold off upgrading to > 6.0 until the M$ option is available.

As noted above, there’s no reason to uninstall to update - unless you got your current release from elsewhere (e.g., fdroid) so it was signed by a different key.

1 Like

K9 works again with an office 386 Email account. On Friday, I reinstalled everything. And it did not work. On Saturday, I used the web interface with Firefox. On Sunday, I start receivind Emails vie k9, without changing anything.

So either MS changed something, or my using of the Web Interface did the job. No idea, but it works

You were probably hit with the temporary Basic Auth rolling shutoffs that Microsoft is doing. I got hit with it yesterday.

According to this article, “Sometime in second quarter of 2022 we will selectively pick tenants and disable Basic Auth for all affected protocols except SMTP AUTH for a period of 12-48 hours. After this time, Basic Auth for these protocols will be re-enabled, if the tenant admin has not already re-enabled them using our self-service tools.”