Support Request: Importing Settings and Accounts

I have a somewhat urgent request. Got a new tablet, installed K-9, and attempted to import settings from existing tablet.

K-9 wrote the settings file. K-9 cannot read the settings file. Same version on both devices (6.603, as current on Google Play).

Yes, I’ve verified the file is not corrupt. I’ve regenerated it on the 1st tablet three times, and copied it three ways (via USB, WiFi, & Bluetooth).

I’m dead in the water on the new tablet until this is resolved. I have a several accounts and individual settings that it would be impractical to re-input by hand. Can a developer, maintainer, or admin please chime in?

Thanks in advance for any help.

Are there different apps that you can use to select the file? If so, use the one from Android, not any third-party file manager


That’s not an issue. It doesn’t matter if the Android file picker is used, or a real file manager. Tried several different options. The settings import function had one job to do. It won’t even say what the error is.

I’ll give it a few days for a developer or maintainer to chime in, and then I’ll have to seek an alternative.

It does very much matter which file picker is used. Only the original Android one can grant K-9 mail the permission to read the file. All others can just return the file path, which apps like K-9 on modern Android versions can no longer really access unless they are approved as a file manager by Google.

Did you try the file picker that looks like the screenshot on this website? Open files using the Storage Access Framework  |  Android Developers Only that one will work.


You get what you pay for.
Ask them to give you your money back.

Yes. The default stock Android file picker was the first one I tried. Not my first rodeo.

Then I guess the only option is to export the logs. See LoggingErrors · thunderbird/thunderbird-android Wiki · GitHub

1 Like