Some Gmail special folders are not showing up in K-9 Mail

so, I’ve been using this app for years with zero issues. I’ve recently installed the latest version of the app from Fdroid, on LineageOS 20.

Since I’ve set it up I cannot seem to get my sent items to display in the k9 mail app. I’ve tried enabling all folders, I’ve tried reverting to the older app password method of authentication, nothing makes a difference.

When I send an email from the app, it works, and it does display in my sent items in the web interface, but no matter what I do I cannot get K9 to show me more than just my inbox. any other folder (sent, bin, spam, etc) simply does not display in the app.

Thanks for any advice.

Sounds like you are using POP3 instead of IMAP

Did you check if the mapping of your local folders is correctly set to the corresponding remote folders?

Thanks for replying; definitely not using pop3, I don’t even have it enabled on my gmail account.

I’ve tried using the automatic setup for gmail, as well as entering all the incoming/outgoing settings manually. Same result for both.

Thanks for the reply; how would I go about doing this, I’ve dug around in the settings quite a bit and haven’t seen anything like this.

Go to Settings / < account > / Folders

It has to be something account specific; I’ve just added another gmail account and it’s working fine.

When I look in the “manage folders” dialogue, I can see the “sent” folder is set to “automatic (none)”, when I select that, the sent folder is not displayed as an option to select. I guess it has nothing to do with K9 mail, but must be something to do with my gmail account?

Honestly not even sure where to start looking to get that resolved, any suggestions welcome.

Otherwise I’ll make sure to post up the answer if/when I find it in case someone else comes across this thread in the future.

Thanks guys.

Well f*ck me. no idea how these settings would have ever been changed, but here we are. As this has basically nothing to do with K9 mail, I can delete the post if needed, but here is the answer inside gmail settings:


Please don’t delete your posts. This could be helpful to someone else.

1 Like