[SOLVED] Cannot add new gmail account - AUTHENTICATIONFAILED

I already have several gmail accounts working fine but I tried to add a new one but I get AUTHENTICATIONFAILED message. It does not let me add a new account. I am using the latest version of K-9.

You probably need to allow access for what Google calls “less secure apps”.
See Check Gmail through other email platforms - Gmail Help especially the troubleshooting section.

thank you, that worked!

So what do i do if i that dont work?

Have you checked whether or not access for “less secure apps” is enabled?


I checked and it is on :

What’s the error you’re getting in K-9 Mail? Did this work before and now it stopped working?

It worked many years ago i stopped using K9 cause of outdated grafics, but now i wanna try it after reading XDA article.

The error is this :

I assume you double checked to make sure the password was entered correctly.

It’s possible that K-9 Mail doesn’t transmit the password in the proper format if it contains special characters. To find out if that’s the problem could you change your password to something using only a-z, A-Z and 0-9 (make sure it’s long and not easily guessable)? If it then works with K-9 Mail we roughly know where in the code the bug has to be.

In addition to turning on “less secure apps” did you use the google facility to generate and then use an app-password? I believe that Google’s generated app-passwords are all lower-case alpha and displayed in four 4-character sets – to be entered without the inter-block spaces.

Thank you, changing my code seems to have fixed it.

@Andee: It would be very helpful to us if we knew which character was causing the problem. Can you tell us what special characters you used in your old password?

I used the randomly generated code from gmail app on android, maybe androids own? i dont know tbh i just generated a new one.

Sorry i cant be of more help, maybe you know if i can see what passwords i have used before?

A post was split to a new topic: Will there be support for using OAuth2 with providers like Gmail?

That worked for me