SMTP setup fails

Setting up outgoing server for SMTP fails (with single exception - see below)

I can set up K-9 Mail for incoming server (POP) successfully, but when I set the corresponding outgoing server (SMTP) the test routine reports:


Setup could not finish
Cannot connect to server
(SMTP response is 0 length)

    CONTINUE     EDIT DETAILS

Mail that I compose on this account ends up in the “Outbox” and is not sent.

I am using the same settings successfully on other devices and internet connections:
STARTTLS
Port 587
Require sign-in
Normal Password

All of this works as intended

I am using:
K- 9 Mail Version 5.806 (latest version on Play Store, 19 November 2021)
Android 11 with security patch to 1 November 2021
Samsung Galaxyt S10e

Exception:
Strangely enough, this error on K-9 Mail does not occur when I am connected to my home WiFi (internet supplied by my mail host), when I can connect and send mail successfully. However, this does occur:
On other WiFi
On GSM

Couple potentials I could see, but nothing authoritative…

  1. The SMTP hostname is written in a way that DNS fails to resolve when you aren’t on your home network.
  2. The SMTP server fails to accept external connections, for fear of security or spam or bad config or …

Either way, you ought to contact your ISP and ask them for the right server name to use on your device such that it works when you aren’t on your network.

What mail service provider are you using, and what hostname are you entering for the SMTP server? It’s possible that the name you are using only resolves when using their DNS (which is likely the case when on their connectivity), but is not configured outside of that. They should have one that is configured to resolve on public DNS. Knowing your mail provider/smtp hostname lets others look at how those details are set up.

I have exactly the same issues.

K9 works in both directions on my home ISP,s network (Zen) it does not send (SMTP) on my phone providers network (3 Mobile) or my sister in laws home Wi-Fi. It receives pop3 mail from any network

I sent an email from my sister in laws home Wi-Fi using my laptop and thunderbird for Linux with no issues worked first time. When I tried to forward the email back on the same network at the same time using my phone that failed. Both email clients are setup exactly the same and use the same provider Zen.

I can telnet to both of the ports 995 and 587 , so the issue is not DNS or a network problem. If I tether my laptop to my phone I can send and receive email using thunderbird but K9 always fails.

The error message is “smtp response is 0 length”

Could you provide the hostname you are using? Also, a screenshot of the error would be helpful.

The hostname of the mail server is maillhost.zen.co.uk

I cant send a screen shot but the exact text on the screen is

K-9 Mail 1m
K-9 mail Failed to send some messages
SMTP response is 0 length

If I tether my laptop to my phone I can send email ( Thunderbird) without any issues over the 3 mobile network. K9 mail does not send ,it gives the above response.

K9 works perfectly on my home Wi-Fi sends and receives email without issues. This appears to be a timeout issue is it not waiting long enough to get a response from the Maillhost server

Do you have the hostname configured as “maillhost.zen.co.uk”? You spelled the first part of the hostname that way twice in your response – is that what you are using or is it a typo?