Skipping over unread msgs

Lately I have a problem when I have both unread and read email in a folder. After reading the first unread email and deleting it or using the > to go to the next email, it jumps to the first read email instead of the next unread one. Can’t find a setting to fix this. Any ideas?