Setup Fails "cannot connect to server SMTP"

I installed the K-9 app from Google Play. The setup failed, “Setup could not finish, cannot connect to server SMTP”.
I have images of the INCOMING and OUTGOING server settings, but I got an error here “Sorry there was an error uploading that file”. What is the error?

This is my first post. How does one add an image to one’s profile?

Thanks for your help.

By clicking on the little image icon and then browsing to the location of your screenshot.

Google your provider settings, like for example “Gmail IMAP settings”, and make sure you entered the right port etc.

Screenshot 2023-02-25 152531

Nimueh, Thanks for your reply.
By clicking the little image icon
I need to split this into 2 topics: 1) Setup Fails; 2) Change Profile avatar.
Stay tuned. :smile:
I had difficulty learning how to access the profile avatar. Through trial and error, I discovered that right-click the avatar and choosing open link in new tab brought up a a page showing preferences, including editing the avatar. I’ll get a screenshot of that page and post it here
Again Stay tuned. :smile:.


I guess I just “got lucky” by stumbling onto this. Surely there is a straightforward way to accomplish this?

A suggestion was made in the Thunderbird forum that I need to confirm that my IMAP and SMTP settings are consistent with those of K9. Here are images of the IMAP and SMTP setting. I got these from Spectrum, which provides connectivity for Email.

I believe that these images confirm that incorrect values for these are NOT the reason for K9 setup problem.

Thanks for your help.

Nope, that’s pretty much it lol. Just click on your avatar and you’ll see “Preferences” on the far right, the little person icon. Then click on Preferences again (or rightclick - open in new tab) and change your avatar, like you already did :slightly_smiling_face:
Screenshot 2023-02-27 193522

It’s been 5 days with no suggestion of a next step. Should I take that to mean the I need to look for some other app for reading Thunderbird emails on my note10+ ?


Double check the server settings and make sure there’s no typo in the server name. If you still run into an error, please post the exact error message the app is displaying.

Thanks for your reply cketti.
The only error message is the title of this topic “Setup Fails “cannot connect to server SMTP””

I doubt that’s the exact error message. The app contains the following string ($error is a placeholder):

Cannot connect to server.

Even if we fuzzy-match this to the text you’ve provided, it implies the value for $error is just “SMTP”. I don’t see how the app could have produced an error message like that. It’s more likely that the information you have provided is incomplete.

Why not just send debug logs? There all information should be available: exact version of K9, exact error, …

cketti Thanks for your reply.
Here is a screenshot of the error message.


What K-9 version is this? (have a look at the settings screen of K-9)

It is version 6.400 and blah to conform to the length requirement

To me, this looks like you entered the IMAP credentials on the POP3 account setup screen. At least the only occurrence of that error message that I found in K-9’s code was in POP3 related areas.

ByteHamster, thanks for your reply.

I guess I may have entered them on the POP3 screen, but I don’t think so. Anyway, I uninstalled and re-installed. Here’s what I got.

Do these look OK?

The screenshot posted by you earlier shows what server settings you should use. Have you tried using them?

For SMTP the port in screenshot you sent earlier was 587, security STARTTLS. In screenshot you used port 465, SSL/TLS.

that’s the least of the problems.

For SMTP the port in screenshot you sent earlier was 587,
security STARTTLS. In screenshot you used port 465,

neither imap. nor exist.

as @cketti indicated, the settings in the setup screenshot posted above are what, from all indications, should be being used. [in searching, i didn’t find any reference to the ones used in those recent screenshots of the setup screens.]

1 Like