Sent folder not syncing for new email account

Hi there,

I have been using K9 for several years now without problems and am pretty happy with it. Until now I had 3 email accounts in K9 working perfectly.

Recently (3-4 weeks ago) I created a 4th email account on a new domain and added it to K9 as an IMAP account.

The problem: The “sent” folder will not show any emails I have sent through K9. It only shows emails I sent either through webmail or through Thunderbird on my desktop computer.

If I log into the webmail account and send test emails, I can see them in the sent folder in the webmail and in K9.

If I use my email program (Thunderbird) on my desktop computer to send emails, I can see them in the sent folder in Thunderbird and in K9.

On desktop or webmail: the sent folder does not contain any emails sent through K9.

Background information:
I have 4 email addresses on 3 different domains.
All 3 domains are registered with and managed by gandi.net
I have K9 version 5.806
The phone is a Pixel 5 running Android 12 with all latest updates.

Attempted remedies:
I have tried removing the email account with which I am having this problem and re-adding it.
I have ensured that Settings > [Account] > Sending mail > Upload sent messages is checked

Solution:

While waiting for a response to this thread I continued to browse through similar questions here in the forum and came across a suggestion to check whether the correct folders had been selected under Settings > Account > Folders. I was surprised to see that almost all the folders were set to Automatic (None). I manually selected all the appropriate folders and tried to send a test email and now it works as expected, a copy of the sent message is stored in the sent folder.

I am pretty sure I never had to do this with any of my other 3 email addresses. Is this something new? If yes, it feels like a downgrade in the user experience.

I had almost exactly the same problem and it’s been killing me! The email account not going to sent folder was my business email and it’s caused me some serious grief on occasion.
I allocated the sent folder and it works perfectly so a big thanks for posting this solution.
To the K9 techs, please change the defaults from (none) to the corresponding folder, IE Sent to Sent, Drafts to Drafts etc, will save people a lot of grief.

I have this problem. I set folder manually