Sending messages

I’ve recently had to leave Sprint and join T-Mobile, and when I did I got a new Pixel 6 pro. Pro. When I set up K9 mail everything seemed fine until I attempted to send an email. The emails are in my outbox and I do not seem to understand how to get them sent.

I am using K9 5.806 an Android 12

My email account is in IMAP one. I’m able to fetch mail and read it without any problems. But unfortunately I do not seem to be able to send email. On my laptop I’m using Thunderbird with the identical server settings that I have on my phone, and I do not seem to have any problem sending emails from my laptop.

If anyone has any suggestions, I would love to hear them

Go to the “sending mail” configuration option and then “outgoing server”. On that configuration page, select the “next” at the bottom right. If there are configuration issues you should get an error popup. If it didn’t encounter a problem connecting to that server you will be returned to the main “sending mail” configuration page.

I have the same problem. When I set my SMTP server, I enter the same information as on my computer, I do “next”, everything is validated, but none of my emails leave.
I have the problem with 2 different SMTP.

What is your K-9 release?

What mail service provider(s) are you connecting to for your outbound mail, and the settings that you are using?

If you select the “outbox” and then use the “send messages” option what happens?

K9 version 5.806

Android V 9
Parameters : SSL/TLS
Port 445
Authentification with crypted password
I use the same parameters on Thunderbird

Android V 8
Parameters : SSL/TLS
Port 445
Authentification with normal password
I use the same parameters on an other Thunderbird too

When I select “outbox” ans use “send messages”, nothing happen, the mails stays in outbox.

I am also using K-9 version 5.806

I am trying to connect to Zoneedit in order to send emails from the domain of mine that they host.(

The server is
with port 465 and security set to “none”

when I click “NEXT” from the outgoing server settings I see the message “Checking outgoing server settings…” with a circle chasing its tail to indicate that it is processing something. After about five minutes, The error message “Cannot connect to server (Unable to open connection to SMTP server)” appears after six or seven minutes.

One other piece of information that might be of help in figuring this out is that I cannot receive emails directly through Zoneedit. Instead Zoneedit has an email forwarding service that forwards messages to any other account I choose. Should I leave the incoming settings blank? Or should I use the incoming messages from another account and server?

On my previous phone (an LG) I was able to send messages through Zoneedit without a problem.

No news, I still have the problem, I’ll change my mail app if I can’t use K9 to send mails.

With port 465 the standard is to have security set to ssl/tls. Port 587 uses starttls. It’s possible that zoneedit uses non-standard settings, but their documentation/examples that I have seen seem to indicate that they use the standard settings.

In order to send mail from a K9 “account” you need both sending and receiving configured for the account. They don’t have to be symmetric so it’s fine to set the receiving/incoming to whatever MSP you are picking up your mail from (as a result of the zoneedit forward) and the sending/outgoing to the zoneedit details.

@Screwy_Squirrel – Are you using port 445 or port 465? Port 445 isn’t used for mail. What is the mail hostname you are using - in both the and cases.

Right, 465, not 445.


As I said, I use same parameters on Thunderbird, my mails are send.

I guess without debug log it is hard to help.
See LoggingErrors · k9mail/k-9 Wiki · GitHub

Now I’ve taken your advice and use my typical incoming settings and combine them with the outgoing settings for Zoneedit. That seems to have cleared up the problem of not being able to set up the account.

But now when I try to send an email, it ends up in the outbox rather than being sent.

@pythagorian - If mail you are composing/sending is remaining in your outbox it sounds like your outgoing mail server settings may not be correct. When you select the “next” in the lower-right on the outgoing mail server settings page what happens?

It would also be useful for you to list all your outgoing mail server settings.

I activated the debug mode, I sent an e-mail to get the required information, the e-mail is gone. Today, it works, e-mails are sent. I’ll see on the other device if it’s okay.

Please tell me how to activate the debug mode. Maybe that will work for me

When I select “next” in the configuring server option, I see a circle chasing it’s tail for a brief moment and then I am returmed to the settings page

The outgoing server settings is for port 465 and START/TLS

The “require sign in” box is not checked

The server name is

Try checking the “require sign-in” option. It’s very unlikely that anyone is allowing you to use their outgoing mail server without authentication.

See also: ZoneEdit - Email Tutorials

I checked the box and the first time I tried to change the settings It said that it failed because I had mistyped my account name. I then corrected that and clicked on the word “NEXT” . There was no error message and I was quickly taken back to the settings page. So I assume that I used the correct account name, and password.

I then tried to send an email and it remains in my outbox. So unfortunately that does not seem to have solve the problem.

Well apparently it took a little time to do its job, but for reasons that I do not understand turning on the error log seems to fix my problem.

I’m very curious why that would be

But regardless, thank you very much for the help.

May I add my slightly different email sending problem? I am using a BT smtp server and sending from my own domain email address via Android v11 and K-9 5.806. The setup follows BT instructions including SSL and port 465. The email appears to go OK without any error message, but in fact is not sent and appears in neither Outbox nor Sent folders. I have a similar problem with a tablet on Android 7.0 and K-9 5.600 except that in this case outgoing emails are saved to the Sent folder but not actually sent or received by the intended recipient. Tbird works OK with the same mailboxes.

Any help would be appreciated.