Push notification message

I am using 5.737 and set it up for push. In the FAQ for push (menu seems to have changed) the notification message says “listening for new emails” but mine says “sleeping until background sync is allowed” I can’t find any option to allow sync any suggestions.

It is a phone setting. On my phone yelling the phone not to optimize this app for battery usage allows it to background sync.

I needed to change K9 Settings > General settings > Network > Background sync to Always, it seems to work OK I have battery optimisation off