Push not working on Android 14 (K-9 Mail 6.800/6.801)

It’s not there on a pixel it seems, there is no advanced section

No such entry on my Pixel 8 Pro / Android 14

This looks relevant to the issue:

and

1 Like

That all sounds way above my knowledge base :rofl:.

It also doesn’t explain why mine has started working again since I’ve added an account again manually.

@ApriliaEdd, when you added the new account, did K-9 appear in the global “Alarms and reminders” page or did the K-9 App Info page show the local Alarms & Reminders entry?

@number6

No k9 does not appear in either of them. The screenshots I posted yesterday were all taken after I had already added the duplicate account.

I was able to fix this by going into my existing account settings (I have two of them), opening up the “Fetching mail” settings, then “Incoming server”, making no changes and then pressing Next. Since I did that for both accounts, IMAP push seems to be working again. Note that a reboot previously did not fix the problem, only accepting the current settings worked.

So does it appear in the Alarms and reminders section on yours now or is it just mysteriously working again like mine?

Still not in the Alarms and reminders section, but now working…

Nor on Lineage 21 which is AOSP Android 14. Looks like a Google change.

Same issue on my Pixel 7 Pro and Lineage 21. Both running Android 14.
Push (and pull) in the background stopped working. They only work if i bring the app to the foreground.

Same. P7P and Lineage rom. Only works on manual refresh.

we have gotten around this two ways, I added a duplicate of one of my accounts and it all started working correctly after that and I removed one of the duplicates. @number6 “refreshed” the incoming mail server settings

I’d try the refresh first if I was you as its less hassle than adding a duplicate account just to remove it again.
Good luck and report back if it works or not.

1 Like

Refresh incoming worked on one device (pixel) but had to create/delete a new account on the Lineage tablet but fixed it.
Not sure if it helped but after that K9 appeared in special access so i could give it permission for alarms and notifications.

As a workaround it seems fine until a proper fix is implemented.

Same issue here on Android 14, Lineage, but also on Xiaomi Android 13.
This happens with almost every update.
This time push is working but notifications are not.

To fix it I rename my accounts and import the previously saved accounts.
Then I enter passwords and delete renamed accounts. That’s it.

For what it’s worth, my Pixel 6a running CalyxOS v5.5.0 does have the “App Info > Advanced: Alarms & reminders > Allow setting alarms and reminders” option for K-9, and indeed I had to enable it to get IMAP Push working again after a fresh install, just as @cketti indicated. However, I also found it necessary to force stop K-9 (again in its App Info page) and relaunch after enabling this option. I just had a few frustrating hours because I hadn’t thought to do that.

For the record, as of K-9 v6.801 there’s no user-visible message explaining why push IMAP is not happening, or even that there’s a problem at all. (It even displays the “Synchonize (Push)” notification like normal!) Most apps I use take great care to prompt for the permissions they need, even the ones they can’t request directly – look at Signal’s chat backups for an example involving the “alarms & reminders” permission in particular – so I really didn’t expect this to be a simple permissions issue. For Google’s sake, here are some of the logcat messages you’ll see if you enable push IMAP and debug logging in K-9 but don’t have “alarms & reminders” enabled:

03-26 16:16:01.176 15020 15058 V PushController: PushController.initInBackground()
03-26 16:16:01.176 15020 15058 V PushController: PushController.updatePushers()
03-26 16:16:01.177 15020 15058 V PushController: ..Starting PushController for accounts: [98a61b62-5ce8-4b25-8934-11438e5eaa01]
03-26 16:16:01.177 15020 15058 V AccountPushController: AccountPushController(98a61b62-5ce8-4b25-8934-11438e5eaa01).start()
03-26 16:16:01.179 15020 15058 V ImapBackendPusher: Not starting ImapBackendPusher for gnoutchd@softwarefreedom.org because the app can't schedule timers
03-26 16:16:01.179 15020 15058 V PushController: ..Running PushControllers: [98a61b62-5ce8-4b25-8934-11438e5eaa01]
03-26 16:16:01.179 15020 15058 V PushServiceManager: PushServiceManager.start()
03-26 16:16:01.181 15020 15042 V AccountPushController: AccountPushController(98a61b62-5ce8-4b25-8934-11438e5eaa01).updatePushFolders(): [INBOX]
03-26 16:16:01.181 15020 15042 V ImapBackendPusher: ImapBackendPusher.updateFolders(): [INBOX]
03-26 16:16:01.181 15020 15042 V ImapBackendPusher: ..limiting Push to 0 folders: []

HTH!

1 Like

Android 14/K9mail 6.801/Samsung S24+

If it helps…

Push has always worked for me BUT after importing K9 settings on my new phone my accounts did not work until I reselected the certificates in Fetching Mail/Incoming Server. This forced me through the ‘NEXT’ route (as described above). I do have Alarms and reminders Allowed.