Problems with NETADDRESS.COM

It’s not possible to sync all folders. K9 shows only In, Out, Sent and Recycle Bin. I can not see all other created folders.

Did you set up your account using POP3? If so, use IMAP instead.

I tried IMAP. Not possible to connect.
I tried all possibilities and entries, I found at Netaddress.

But, no. No connection.

SMTP is for sending mails.

For fetching mails you need to choose between POP3 or IMAP. @cketti proposed to use IMAP for fetching.

I don’t know, if my English is so bad.
So again:

If I use POP3, I can check my mails. I see all new mails und can write mails. But I don’t see all folders. Only In, Out, Sent and Recycle Bin. It’s not possible to move a mail into an other folder (maybe Spam), because they are not shown.

If I use IMAP, it’s not possible to create a connection.

You seem to confuse SMTP and IMAP.

1 Like

More reason to remove the POP3 option from the app.


Sorry. My mistake. Don’t know why. Could be my age.:laughing::wink:

But POP3 works with
And SMTP not. That’s my problem.

Did you type in the SMTP server address or the IMAP server address? In your previous post, you mixed them up again. Make sure to use the right server address. Maybe a screenshot of your account setup screen (with the server details but without your address and password) could help.

I used the entries I can see at the Help-page of the Home of Netaddress.

And that’s the next Screen:

That’s all I have:

Have you tried without compression?

Yes. I have. Same result.

Hmm, your settings look good to me. The error message “improper syntax” sounds like the server somehow doesn’t like something that K-9 is sending. Maybe @cketti can say more here. I’m out of ideas.

The capability response of doesn’t include any SASL authentication methods. In that case K-9 Mail falls back to the LOGIN command. If the password contains a non-ASCII character this might lead to an error (because arguments to the LOGIN command may only contain ASCII characters).

@Oskar_Schonherr: If your password contains any special characters, try changing it and see if that works.
You should also ask your email provider to configure their IMAP servers to follow modern standards (at least allow SASL PLAIN). If that fails, my recommendation would be to move to a different email provider.

1 Like

Thats the password requirements. Some symbols are necessary. But symbols are required also with other mail accounts. And it looks like it works perfectly with POP3. All my other accounts work with POP3. All of them. And all of them are using also symbols.
So for me IMAP seems not to be a useful solution.

Using an different mail provider is also not a very helpful idea. Do You buy a new car, if the tire is down?
(This idea is like: You should use an other mail app.)

Password requirements:

Passwords should be changed on a regular basis.
Passwords must be at least 8 characters in length.
Passwords must contain at least one character from each of the following groups:
• Lower-case letters (a-z)
• Upper-case letters (A-Z)
• Numbers (0-9)
• Symbols (!, @, #, etc.)
Note: Passwords are case-sensitive.