Outlook.com Mail Settings

Hi, outgoing email settings for Outlook.com email accounts have stopped working in the last day or so. Incoming mail works absolutely fine as usual but unable to send outgoing mails. I’m experiencing this with two different Outlook accounts on separate devices so I’d guess the issue is down to Microsoft changing something at their end?
Something similar to this happened about a year ago which was down to missing OAuth 2.0 authentication which was addressed in K9 and resolved the issue. Maybe this issue is similar in nature? All other outgoing configurations are set as per Outlook guidance but no luck.
Any help on this would be massively appreciated!

1 Like

Indicating any actions you have taken to see if you can get this working again (e.g., going through the “outgoing mail” setup) and any errors you received would give people something to work from. Including your outgoing mail settings and your K9 version number would also be useful.

When sending mail K9 will provide two notifications (“failed to send some messages” and “authentication failed”) then when configuring outgoing mail K9 can’t complete the task. See attached screenshots…


K9 version is 6.4.
And outgoing mail settings are unchanged and as attached…

It doesn’t work for my test account either. Nothing in K-9 Mail has changed. Please contact Microsoft and ask them to fix their servers. Or better yet, switch to an email provider that doesn’t break IMAP/SMTP access every other week.

1 Like

I am having exactly the same problem right now.
I use thunderbird on desktop and have had no issues sending my mail.
If no settings have changed on either thunderbird or k9 mail, then is there any reason why only one of them can no longer send successfully?

Then you’re probably not using OAuth2 for authentication on Thunderbird. Have you tried using password authentication in K-9 Mail, too?

I’ve just managed to get the outgoing mail working on both devices (a tablet and phone) for both outlook email accounts by reverting to password authentication (instead of the OAuth2 authentication which had been previously required to enable outgoing mail). So I guess Microsoft have changed something at their end (again!).
I’m happy it’s back working, but for how long…

1 Like

Yep, I just finished testing this same thing.
Used an app password for authentication and send works.

Thank you for this, I found out this week that none of Microsoft accounts could send from my phone… I’ve changed as suggested and it appears to work .
Thank you .

This broke for me recently, or at least I only just noticed.

OAuth2 work fine for fetching mail, but for sending it doesn’t. I get the same “authentication unsuccessful” error BillBobbins has posted.

I’ve seen different SMTP server addresses listed in various places, including in Microsoft’s own documentation. I’ve tried smtp.office365.com and smtp-mail.outlook.com . Both fail.

I get the same error when setting the account up from scratch.

I was able to get one of those servers to prompt me to log in / allow access for K9, like an initial OAuth2 setup should, but it still ultimately failed.

Does anyone have OAuth2 currently working for sending mail for an outlook / hotmail / etc. account?

Hello everyone!

I’m in the same case as you and the solution provided by @BillBobbins doesn’t seem to work anymore. Even by setting the authentication on the password, i’ve got the error message concerning the authentication.
It’s a bummer that it can’t work natively as it should be with a Microsoft server.

If anyone has an idea :wink:

Hi everyone!

Little update on this topic as I managed to solve the issue for both my accounts (outlook.fr and hotmail.com).

For the IMAP server, I had to select the following options:

Encryption method:SSL/TLS
User name:my email address
Authentication:OAuth 2.0

For the SMTP server, I first had to create an application password into my Microsoft account (Security settings > More settings > Create an application password). Then I used the following options:

Encryption method:STARTTLS
User name:my email address
Authentication:Normal password (put the application password generated earlier)

I hope that can’t help some of you!

1 Like