No POP3 email from IONOS/GMX - "Unable to execute POP3 command"

As of early this morning (Mon Jan 24 2022), neither my wife nor I are receiving email through K-9 on our Pixel 3XL phones. We do receive email though Outlook on a laptop or through webmail. When I go through Settings for Incoming server setting and click Next, I get an error of “Setup could not finish. Cannot connect to server. (Unable to execute POP3 command)”. Same thing happens on both phones. Reboot makes no difference. Any suggestions?

3 Likes

Unless you changed something in your K9 configuration, it is rather unlikely that this is a K9 issue. Rather I suspect that your mail service provider made a change or otherwise “broke” something.

That said, in order to try to give suggestions some basic details are needed:

  • K9 release
  • android version
  • provider server address (incoming/outgoing - these may be different)
  • security
  • port (retrieving and sending)
  • authentication [password authentication type]

I did a quick search for the server name for IONOS’s pop service and ran into a dns issue. I don’t know if the information I found on my search was accurate or not.

1 Like

Same exact problem. Early AM it stopped working. Running K9 on two different pixel 6 pro phones with Android 12. Ionos pop mail accounts.

Tried ssl and unsecure with port 110. All no go.

As a workaround I removed all app data and set up the mail accounts as IMAP and everything is working on both phones.

The only changes were: Both phones installed the January Google security update. Also installed “Google connectivity services” update via play store.

Ionos pop mail works on PC’s just fine. So this problem is limited to the device and app. Just don’t know what broke it exactly.

Edit: the same pop account and settings works perfectly in Gmail for Android. Samsung mail also working for pop mail…

3 Likes

On both a pixel with android 12/k9 5.909 and an essential ph-1 with android 10/k9 5.909 I get an “unable to execute POP3 command” error when trying “pop.ionos.com” on 995 and 110. The ph-1 hasn’t had any system updates in some time. So, I suspect that this isn’t due to system updates. Rather the MSP may have made a change to their support of POP that is incompatible with K9’s POP support. You probably need to capture a debug log so that the developer can take a look at what is going on.

I enabled logging. Where would I find the log file? Tia
Also SMTP works fine. Edit: seems I have to get the log via adb. I’ll do that and submit it with a bug report.

1 Like

I HAVE SAME PROBLEM, I CALLED IONOS, all is right with them. it must be a problem of k9-email app

1 Like

I also have this issue (Unable to execute POP3 command"), Android 12 on Pixel 4a. Outgoing ionos email works from the phone. Incoming works fine for gmail account and both work fine from Windows laptop.

2 Likes

I also have the same issue which began last night, I have K9-Mail 5.806 version and I can send emails using IONOS POP, but cannot receive them on my phone. I get the same error as the others above.

1 Like

See Can't connect to POP3 server (IONOS, GMX, maybe others) · Issue #5879 · k9mail/k-9 · GitHub

Unless the providers will change their server software again, you’ll have to wait for an update of K-9 Mail to fix this issue. The plan is to release a new beta version later today.

Update: The providers probably also support IMAP. You could try setting up the account to use IMAP. That’s a far better choice when using K-9 Mail anyway.

Just to add mine to list, having same issues with Ionos using Samsung Note 10, K9 5.806, speed working from this morning.
Samsung email app can access emails on ionos server using what appear to be same settings as used on K9.
No issues accessing on outlook on Laptop.
Will look out for update to K9

1 Like

Same problem here: Galaxy S10, Android 12, GMX, POP3
K9-Mail v5.909

Sending works.
Retrieving not working.

Hopefully this get fixed fast.

1 Like

Same here, two different phones (Samsung S8, Honor 8), two different providers (GMX and private domain at a local provider).
Creating new account fails as well.

1 Like

Same Problem here, on two different phones and multiple Mail-Adresses

Connecting via POP3 to GMX Mailserver fails with same Error-Message

1 Like

The latest beta version should fix the issue. Beta: K-9 Mail 5.910

3 Likes

Confirmed working for me. Huge thank you for jumping on this so fast.

Beta resolved the issue for me too. Thanks for resolving it so quickly.

I have same problem. Pixel 6 Android 12. Started couple of days ago. Will try beta

Please stop posting that you’re experiencing the same issue. This information is not useful to anyone and is only adding noise. The problem has been identified and a fix is available in the latest beta version (5.910).
If that fix doesn’t work for you, please do let us know.

If we don’t get reports of the fix breaking things for other users, we’ll release a new stable version (5.807) with the fix in the coming days.

6 Likes

Same issue on my Samsung A41 and A51, K-9 Ver. 5.806. It looks like a general issue for all IONOS users, other devices works well with the same mail-account.
You better solve the issue soon! Otherwise I will be forced to use another mail-app on the mobile phone.

Installed the Beta Version 5.910 - the mail app works smoothely as before…

1 Like