No incoming mail

K-9 has stopped receiving mail, was working OK until a week ago. If I try to receive mail I can see the top line flashing as though mail is being received but nothing is displayed. I can send mail OK. What can I check?

K-9 5.807
Samsung Galaxy A3
Android 8 (I think)
Receiving mail from Sky Yahoo

Yahoo has been transitioning users to OAuth2. With clients that don’t support that, including K9, you need to set up/use an “app password”. I would, however, think that this would impact both your incoming and outgoing, not just one side, assuming you are using their servers for both.

I’m assuming that you have looked at your mail with another client/webmail and can confirm that you have received new messages.

If yes, then the first thing to try is in “/settings/fetching mail/incoming server” select the “next” in the lower right and see what response you get. If you get an authentication error it may be the OAuth2 issue. In that case you should be able to find help information on the yahoo site explaining how to do that (it’s also findable in previous forum items).

If that’s not the issue …

  • are you using IMAP or POP?

  • what are your incoming and outgoing server settings (please list separately):

    • server names
    • security
    • port(s)
    • authentication type
1 Like

njeyaakili, thanks for your reply. My mail gets copied to my PC so, yes, I have received new messages.

When I look at K-9 settings, incoming server, it said something about an invalid certificate. I clicked ‘accept’ & I now have mail.

Thanks for your help.

Good that your mail is working now, but interesting that you got a certificate error. You shouldn’t from any provider that is on top of things.

What is the server name for your incoming mail server? I can look at their certificate and see what its issue might be.

Sounds to me like a hoster offering MX through their domains for customer domains.

E.g., there is If you host with them, your mails are fetched from a server like This leads to a certificate mismatch if you are fetching for your own domain (such as from this server. To circumvent, one can either ignore the certificate warning when fetching from, or one can directly fetch from * The username and password is the same either way as the physical machine behind both MX entries is the same.

Other providers known for such issues in the past are, and even Yahoo. One used to fetch from protocol specific servers such as while the certificate they used was only issued to However, I think they fixed this by using proper (wildcard) certificates now.

Incoming mail server is