Messages not shown after TB mass import

Hi! The other day I mass imported close to 8000 eml message files, all of them a few years old, into the Inbox. I used the Thunderbird plugin “ImportExportTools NG” to do that.
After the import, everything looks good in Thunderbird, including all the imported messages.
In K-9 Mail, on the other hand, things are not that good… I have configured it to download the latest 2000 messages and display only the latest three months. After I made the import, only the emails received AFTER the import are shown.
I don’t know enough about IMAP to determine if this is 1) an unavoidable problem, 2) a problem with Thunderbord and/or the import plugin or 3) a problem with K-9 Mail.
What do you think?
/Martin Leben

I don’t use thunderbird much but I believe that, at least with certain settings, it uses a machine-local cache to display your messages. Did your import push the messages to your IMAP server or only import them to thunderbird’s cache? Did you look at your IMAP server’s inbox with another client to see what it finds? I did a quick read of the writeup for the tool you used as well as the one it was derived from and it’s not obvious that they push the mail to the IMAP server.

Hi njeyaakili,
All messages has been pushed to the IMAP server. I verified by using webmail at the email provider, and the webmail client and Thunderbird agrees on the number of messages in the Inbox.
BR /Martin

Hi again!
To clarify things a bit, I now have these settings:
Local folder size: 500
Sync messages from: any time (no limit)
See attached screenshot from the Inbox. You will notice that close to the top, I see the messages which have arrived after the mass import. Below the new messages, you will see the old imported messages (with the newest being from 12:th of November 2016), but nothing in between. In order to see those in between, I guess I would have to raise Local folder size to more than 8000 messages, which I would not like to do in order to not fill the memory…


K-9 Mail downloads the N messages most recently added to the mailbox. Importing old messages will cause old messages to be in that set. This issue is tracked here:

Oh, thank you for the pointer! Have a nice day.