"Mark all as read" not available in the Unified Inbox

I have only one email account added to K9. If I start the app, sometimes the inbox of it is selected, sometimes the combined one. The problem is, that I can’t mark all emails as read in the combined one. Kind of annoying to change it to the inbox.

Any suggestions?

1 Like

Sounds like you’re not really using the Unified Inbox. You can disable it under Settings > General settings > Display > Show Unified Inbox.

Alternatively, you could select Select all from the menu, then mark the selected messages as read. This will only affect selected, i.e. downloaded messages, though.

That solves my problem. Thanks.

But is there a reason for not having read all for the combined inbox? Kind of unintuitive.

I guess because nobody has built it yet. “Mark all as read” for a single folder sends a single command to the server marking all messages in that folder as read. For the Unified Inbox we’d have to send one command per folder that is included in the Unified Inbox.