Mail in sent box not sending over internet

Thanks for the tip jd47 - I just noticed that my imap mail on K-9 wasn’t showing in my mail sent folder server side. Easily corrected when I spotted my error on re-installing K-9 to my new phone
Account Settings \ Folders \ Sent folder - when selected, was set to “none” :man_shrugging:

It is September 2022, I am using K-9 version 6.202 dated 2022-07-26 (latest & greatest in Google Play) and I am experience the same exact issue: My sent messages show up in the Sent folder on my smartphone’s K-9 but they never reach the destination (my own Google email account).

I verified all SMTP settings in my K-9 are correct (SSL/TLS, port 465, No client certificate, correct SMTP server name, username and password).

If I try to change K-9’s client certificate, I keep getting a “K-9 Mail keeps stopping” error pop-up.

I also verified ‘Upload sent message’ is checked and ‘Sent folder’ is selected ‘Sent’.

Additional ideas how to solve this?

what are your settings for:

- SMTP server [name]
- authentication [type]

there are a handful of smtp hosts that don’t play by the rules, which may be your issue.

I have the same problem. Nothing worked, I tried old versions too!

@Seeker_of_the_Self : this error seems different to the others. I did not see that others got an error message.

The port you are using for SMTP (587) seems to be for STARTTLS. Did you select it for Security setting in K9?
Also according to Help - How do I set up Posteo in an email client? (POP3, IMAP and SMTP) -
your provider writes:

We recommend using TLS instead of STARTTLS if possible.

Make sure you use the correct port for selected Security setting.

Nope, nothing of this is working,

that “socket timeout…failed to connect” error may imply a network routing, not k-9, issue. there are various IPv6 peering/routing problems, which may be what you are falling afoul of. if you have a desk/laptop (with traceroute and telnet) on the same IPv6 network as your android device (maybe by using the android device as a hotspot) you can potentially see if that’s the issue or not. there doesn’t seem to be a(n obvious) way to force an android device to use IPv4. if this is a wifi, rather than mobile data, connection you may be able to force IPv4 there (if you control the wifi side).


I don’t understand the problem out of the sudden
I couldn’t send Emails, now they just stuck in my outbox and I’m getting these errors. I’m just using the mobile network because here is no Wi-Fi where I am right now. I can just use my mobile. When I try to send mail from my Email Provider it works but not with K-9 but I didn’t change anything in the settings.

can someone send me his/her settings and I’ll try with them? does this make sense?

the settings you need to use are based on your provider’s requirements - settings for some other provider may be of no value. you should look at the document for your provider that stphn references above.

providing your k-9 version, android release and the following from your “sending mail/outgoing server” configuration, might also be useful:

  • SMTP server [name]
  • security
  • port
  • authentication [type]