K9Mail does not synchronize between different devices

Good morning,

still searching for some settings, I see that K9 Mail is not synchronizing between two different devices. I installed the app on my smartphone and on my tablet, and it happens that I marked some mails as read on one device, and on the other device these mails are still showing as unread.

I am rather sure that there is a setting to synchronize, but I have not found it yet. Anyone here to help me out?

Are you using IMAP mail? If you expect message status to be consistent across devices, you need to be using IMAP.

Hi there, I am rather sure that I do, but I would like to check once again. What must I do then to find out?

You check in the Incoming server settings under Fetching mail in the account settings.

Thank you once again. I will try it and will come back should it not work!

First of all, I am using K9Mail in the German version, so I do hope that I understand you clearly.

Yes, I am using IMAP obviously. So how do I synchronize between my devices? Only by using IMAP, or is it anything else to adjust?

Sorry for asking all these questions but I had been using another email app for long time, but this app is going to be discontinued within the next few weeks, therefore I have to look for an altenative.

Can you share more detail on what you want to synchronize? IMAP should already take care of keeping your messages in sync. Contacts are handled by you’re native Android apps.

Oh sorry, I suggested that my message was clear but obviously it was not.

I would like to synchronize all messages that I handle with K9Mail, incoming and outgoing. And you are right, everything else is being handled by other apps, contacts, calendar, etc.

I use K-9 with IMAP. My read messages, and starred messages are consistent across various devices and clients. I tend to have less emails in my K-9, but that is desirable in a mobile device and older messages can be retrieved if necessary.

Maybe I am already too old for this kind of stuff, but my mails don’t.

On my smartphone I had read my mails (4 mails), I deleted the ones that I did not want to keep (2 mails), and at the same time on my tablet I still could see 4 mails. Which means there was no synchronization.

Maybe there is a certain setting that I have not recognized yet? I do not have sleepless nights without syncing, but I always want to have things like this in a consistant way, and presently it is not consistant.

On each of the devices, do you have the:

setting[/account]/fetching mail/sync server deletions

box checked?

1 Like

I can certainly appreciate that. In addition to the setting that @njeyaakili asked about, how often do poll your server? If you manually refresh the additional device, does it catch up?

Yes, this box is checked already.

I changed the setting to manual refreshing now, and at the moment, it does not. So maybe, it would be an idea to wait for some time now and then look what is happening. Presently, I am receiving not too many mails, so I just give it another try.