K9 v5.800 - Individual ringtones don't work (Solved)

Sorry, but my first post seems it doesn’t work. Now I try again.

I use several email accounts. Where can I set in version 5800 individual ringtones?

A lot has changed since the update to 5800 and I am also totally dissatisfied. Above all, I can’t find anything to assign an individual ringtone to each mail account. Has that been rationalized away or where can you find it now?

I have now managed to create an individual tone with an account (gmail). You have to go to “Settings” in the list of accounts. Then select the respective account. Then on “Notifications” at the bottom of “Notification Settings”. Now select the respective account again on “Miscellaneous”. Now tap “Important”. Then click on “Advanced”. Now on “sound”. I have set the desired ringtone for each of my 3 mail accounts. But as I said, it only works with the G-Mail account. With the other two, only the standard tone is used. By the way, I use Androis 11.

Update:
I have now got my desired ringtone for my gmx account. The curious thing about it … instead of from the internal memory (own ring tones), I simply took a ring tone from the original list. Now it is not this tone from the original list that rings, but the one I want from my personal list. :joy: Strange everything. What still doesn’t work is freenet. No matter which ringtone I choose, the standard tone always comes out.

3 Likes

Very stupid of me to allow this update.
Now every email account has the same notification sound.
Before I had one for each email account.
I search dumb and goofy through the menus but can’t find a point to change the tone. Not even with the path that is above.
Why do software updates always have to be shit ???

You can configure notification sounds via Android’s notification settings. Each account has it’s own settings there. K-9 now simply uses the “modern” (since Android 6?) way of configuring notifications.

1 Like

No, this works not fine. Only 2 of my 3 mail-accounts works. Android’s notification settings is the problem. 9K-Mail does not even access the ringtones itself. THAT is the problem. Before version 5.800, k9-mail had its own access to ringtones. I use Android 11

@est58
Yeah, that’s really bad. In my instructions above, 2 out of 3 email accounts work. Freenet does not work. Always the same ringtone. In the settings you eventually end up with the Android system settings. And only here you can assign individual tones. 9K-Mail does not even access the ringtones itself. Sorry, for my english. Goggle translate is my friend :wink:

You are using Android 11.

So Android guidelines tell that you will have to set the notifications in the notification channel. Please do.

K-9 is just doing what Android requests nowadays. So K-9 Mail can be used in current Android versions.

2 Likes

The update to 5.800 looks good, but these notification settings are annoying. I also have several accounts and I have my phone on vibrate most of the time. In the previous version I could configure the vibration pattern to be unique for each account but I see no way to do that now. Not only that but now my emails have the same vibration pattern of other apps like whatsapp and snap chat etc. Really disappointed by this.

@Justin
Please read above. I’m in the notification channel. But IT DOES NOT WORK: Look here. The sound you see, is the sound which i wish. But alway I get the standard sound.

I have now set the sound “harmonics” as the standard tone. So I now have the desired tone in my freenet account. But that can’t be the real solution.

For everyone, I do the following:

  1. Open K9-Mail
  2. Tap the 3 lines in the top left
  3. Select any account and click on “Settings” at the bottom
  4. Now select the account for which you want to adjust the sound from the list
  5. Click on “Notifications”
    5a. choose to post new messages
    5b. Notifications folder select “all”
    5c. select “for own messages”
  6. Click on “Notification Settings”
  7. Now you are in systems settings
  8. Now select the account again from the list for which you want to adjust the sound and select “Miscellaneous” (and do the same by messages” (Nachrichtenanzeige))
  9. Select “Important” and select “Pop up on screen”
  10. Now select “Advanced” and choose your desired tone.

This worked for 2 out of 3 accounts. Just not with freenet. With freenet only with selection of the standard tone.

Why “Miscellaneous”?

What about “messages” (Nachrichtenanzeige)?

Yessss…that’s it. This is the solution. Thank you very much. :crazy_face: