K9 mail suddently failing authentication

As of Friday, my IMPA authentication is failing on K-9 mail on my android phone. I believe an update was pushed. This mail account still works on all my other devices. Any thoughts what might be the problem.



I guess you meant IMAP instead of IMPA?

Please send more information

  • what exact version of K9 do you use
  • which mail provider?
  • maybe also which phone / OS

If mail provider is Gmail you might now suffering from their switch towards OAUTH2. In that case please use search function on this forum as there are plenty of threads describing this and possible solution.

From the information that I’ve seen, the impending google/gmail access control changes aren’t going to go into effect until May 30, so not likely the issue here (rashly assuming gmail is being used). Also, while the information is a little obtuse, from what I can tell the May 30 change applies to using ones google login password with 3rd-party apps. It appears that app-passwords will continue to provide access, so K9 will continue to work - if you use an app-password.

Sorry about that, middle of the night posting. Not being clear.

I use my own mail server that uses IMAP for incoming mail (definitely not google). I am using K-9 mail version 5.807, (which seems to have been updated to that version by the google play store on Friday.) My phone is a Motorola g(6) play running android 9.

Please see LoggingErrors · k9mail/k-9 Wiki · GitHub

Also, as it’s your mail server, you should look at its logs.

Barak, have you been able to resolve your issue? I started experiencing the same thing using IMAP on my Chromebook. I have updated to the current K-9 6.0 to try to resolve it, but that did not help.

Was there perhaps a change in the version of some server software relating to authentication that K-9 requires? If so, is there some way to manually reset that in the K-9 app setting?

Which mail provider? If it’s Gmail then that has to do with them enforcing OAuth now and you need to set an app password for K-9 in your Google settings. Please use the search function here if you need more infos, or check Google directly.

K9 6.0 for Chromebook, as I stated, though the issue started a few weeks before the recent upgrade to 6.0.

The mail server is private, run for many years by my son, a senior sysadmin. I will ask him to look at the logs. If Barak has done that and resolved the issue, hearing what he found, and what he did to resolve it, might be worthwhile.

I solved it by uninstalling k-9 mail and installing spark mail. Worked like a charm.

1 Like

This helped you by using a different client.
But it did not solve the issue with K9 and does not help the Dev to fix a potential issue in K9 which could hit others as well.
Did you at least send a debug log as requested by the developer?

Good luck with Spark Mail