K-9 not working on Data

I am using K-9 for an IMAP email account on my Motorola Moto g31(w). It works fine when I am on wi-fi but when out of Wi-Fi range, although all other data services are working fine, I receive no emails whatsoever.

Looking at previous related posts, it is suggested that I “disable connection management” in my Android settings. But I cannot find such a setting to change! I’m using the latest Android 12.

Please, how can I get K-9 to work when not on Wi-Fi?



this is sometimes caused by an IP [numbering] version “mismatch” issue.

when on wifi do you have an ipv4 or v6 (or both) address assignment? when on cell data what do you have? this is generally shown in the device “settings/about phone” item. also, so that we can look to see what it is using, what is the hostname that you have configured as your incoming server?

Thank you.

WiFi is on ipv6 (which I found under WiFi MAC address)
I cannot find the equivalent for cell usage, although I’ve looked everywhere.

I’m using host: imap.gn.apc.org


on reconsideration – an app like:


is better for seeing what your connecting out with as it will show both your private and public IPnumbers. the public number being the relevant one in this context.

1 Like



Public IP

Is that what you need?



so, your public IP for your wifi is v4. when wifi is off, what shows for your mobile data connection?, although I have to admit that means nothing to me …

my thought was that it was possible, though admittedly unlikely, that either your mobile data connectivity was IPv6 and your provider’s host and your wifi was IPv4 (or potentially the other way around). from your information, it appears that all parties are running IPv4 so that’s not the issue. it could be a routing issue, but you’d have to poke things a bit to be able to prove that. a tool like:


is good for that. a ping or traceroute can be telling.

can you send mail while on mobile data or does being on mobile data impact both sending and receiving? your provider appears to use the same host for both imap. and smtp. (receiving and sending) services. if it’s a connectivity issue then both should be impacted.

When you are on mobile, can you refresh/fetch mails manually? Do you have set pull or push for mail fetching? What error (if any) do you get on mobile when you try to fetch manually?

Just to add to the confusion it seems I can actually send messages via data … just not receive…

Thanks for the suggestion of the extra app but I don’t think I have the technical expertise to be poking and the like.

My email provider, Greennet, have checked all the settings and they can’t understand it either…

Thanks for the suggestion, but I can’t see how I do fetch manually?

When you are in Inbox (or any other folder) just drag the list of mails down. When you are at top of list it should trigger manual fetching

Yes, it looks like it’s trying to do something (the timer shows briefly) but nothing comes through and no error message is displayed.

What happens when you test the incoming server in the account settings?

1 Like

I get this error message:

The server is missing this capability:

When I connect to imap.gn.apc.org it announces the STARTTLS capability. It’s possible that your network is using some appliance that tries to downgrade the security of the IMAP connection. It’s also possible that your incoming mail server announces different capabilities depending on where a connection originates. In any case, K-9 Mail refuses to fall back to an unencrypted connection.

You could try changing your incoming server settings to use SSL/TLS.


Yes, that works! Thank you all so much for your help.