K-9 Exchange server option is not showing

I want to add exchange server but its showing me options of I MAP and POP3 no exchange option?

Exchange is not supported.

Which should definitely be changed. Support AWS/Active Sync now.

K-9 Mail will focus on open email standards. Exchange ActiveSync is not on that list.

1 Like

I’ve a school account, which is set up in Outlook (offlie office package installation) as an exchange account, and is full functional (incoming, outgoing).
In K9 I’ve set up incoming email to IMAP-Server “outlook.office365.com” (with SSL/TLS port 993) and full email adress as user name and password. This is functioning !!!
But outgoing setup don’t go, although choosen setup

SMTP-Server = “smtp.office365.com” (with STARTTLS port 587; autenthication not checked)

is passing the server test after clicking on the ‘further’-button (without notification of an error !).
But nevertheless the email over this account remains in the outgoing-folder and isn’t actually sent.

Could you please give me a reply, what is the reason. As mentioned above it couldn’t be “a half” support of exchange (only incoming), or?
Best regards

By:

with STARTTLS port 587; autenthication not checked

I assume you mean that the “Require sign-in” box isn’t checked.

If so, I wouldn’t expect things to work as no self-respecting MSP (at least any that what to have a chance of not ending up on blocklists) will allow unauthenticated users to send mail through their servers. You will need to enable “require sign-in” and provide the appropriate credentials.

If I do so - check the box “require sign-in” - (with same user name and password as in incoming settings), I get the error “user name or password wrong … SmtpClientAuthentication is disabled for the Tenant. … …
Enable or disable SMTP AUTH in Exchange Online | Microsoft Docs” !

In outlook (office package as mentioned above) does outgoing email function over this exchange account.
What does this mean ?

From the error message you included, it appears that your institution has disabled the standards-based imap/pop “submissions” protocol. This is controlled by the administrator and set either globally or at the mailbox/account level. You will need to talk with your mail system administrator to see if they can provide you with an option that will work with the K9 - imap/pop standards-based “submission” protocol.

Many thanks for your answer.