K-9 5.6.00 not notifing me

I am using Android 11
K9 5.6.00 with a POP account
Fastmail for email host with a domain

I noticed even though K-9 is set to check every 5 min, it’s not letting me know that I have new emails until I open the app? Is it supposed to do that? Why isn’t it checking every 5 min and playing the sound that I picked out to let me know that I have new email?

And no, background data restriction is not on.


The current release level (what you will find in the google store) is 5.8.x (and the beta is 5.9.x). I don’t believe that 5.6 is being supported any longer.

1 Like


I noticed that as soon as I turn off wifi, my emails get downloaded. It’s so weird!

I remember that on my son’s Samsung S7 he also experienced something similar: it worked for some time and then stopped. Once changing the network it worked again for some time.
If I recall correctly then it had been solved by disabling all kind of optimizations - Samsung is known to do aggresive optimizations on apps.

My phone is a BLU branded phone on Tracfone.

What do I need to disable?

I do not know that phone - sorry.
But maybe that will give you some directions:

Thanks, I found some of the things that they talked about

I turned off battery optimization for K9, and gave k-9 unrestricted data access and turned on allow K9 to run in the background. All my other apps I have turned off to run in the background.

Now I just have to wait for something to come in.

1 Like

I think that what you told me to do ( that link you posted) worked!

I’ve been getting emails both on wifi and off of wifi all evening!

It looks like turning off Batery Optimization helped and doing some of the other steps too.

Thank you!

1 Like