Issues with "New Message" Screen

I am having issues with the New Messages screen. First, it seems to randomly popup. Second, after messages are displayed in it, they seem to mysteriously disappear. They don’t show up in any of my folders including Trash so it seems they are being permanently deleted. I like the idea of this screen but it shoukd show up consistently and not delete email unless I ask it to. Is there a way to turn it off?

Welcome to the forum, @GLP :wave:

When there is more than one notification for new messages in an account, there will be a “summary” notification. On Android 7 and newer this notification can be expanded to show the individual notifications. Tapping those individual notifications will open that message directly. Tapping the collapsed summary notification will do the following:

  • If all messages belong to the same folder, the message list of that folder is displayed.
  • If the Unified Inbox is enabled and all messages belong to folders that are included in the Unified Inbox, the Unified Inbox is displayed.
  • If there is no regular message list view that would display all new messages together, the “new messages” screen is displayed. The message list will only show messages for which a new message notification was created. Once a message was opened for viewing it is no longer considered “new”. Leaving the “new messages” screen will mark all remaining messages that haven’t been opened as “not new” (the notifications for them will have been removed when tapping the summary notification).

The “new messages” screen will not delete emails unless you use the delete action. It’s just a filtered view where opening a message changes the value that is used to include messages in the list.

I think I know what happened. I had messages come in which were placed into my Inbox and Bulk Mail folders. I didn’t realize that this “New Messages” screen was pulling from outside the Inbox, so I was only looking in the Inbox and Trash folders while the message I thought was being deleted was actually in the Bulk Mail folder where I didn’t look for it. Thanks, that makes sense!