Incoming emails

As of 1/5/2022 I stopped receiving emails. I have tried manually but it is still not working. I saw another person mention that Verizon email uses Aol server & that applies to me too. I just joined this forum. Whats funny that when k9 sent me the link, it only appeared in Aol enail…

Are you using the correct server settings? See Configure POP and IMAP settings for AOL Mail accounts - AOL Help

AOL/Verizon are switching from using your regular login pw for email clients to OAuth2. I believe that they have been rolling this out across their userbase, so it may be that this was just implemented for your account. K9 (and other mail clients) doesn’t support OAuth2, yet. For that case you should be able to create and use an “app password”.

To test things, go to: “settings//fetching mail/incoming server” and then select the “next”. That will connect to the server and test your credentials. If there is an authentication error (and everything worked previously and you haven’t changed anything of late) I suspect that you have been switched to OAuth2. In that case, look at for information on setting up an app-password for AOL.

I have the same issue
do not receive emails anymore since saturday
I am not an AOL/verizon user
someone an idea how to fix that pls?

Well, my crystal ball isn’t working today … you need to provide detail:

  • K9 version
  • mail service provider
  • mailbox type - imap/pop
  • imap/pop server name
  • security
  • port
  • authentication (password type) setting

and do minimal checking. Try the “test” that I describe in the second paragraph of my reply above.

If you haven’t changed anything (including the push/poll options) in your K9 settings since before you stopped receiving mail it’s highly likely that it’s due to a change your MSP made. Maybe they notified you, maybe they didn’t, but you might want to do a search to see what their documented IMAP/POP settings are and compare that to what you have configured.

I have this issue today after install the last version 5.908
I have two different accounts with the same issue.
The email doesn’t work (send/receive) when the phone works with the wifi connection. The email WORK when the phone use the 4g connection…
This is very strange…
I have an android Galaxy A32g


Updating the K9 version is rather unlikely to have an impact on its working when you change from one form of connectivity to another. That said, my crystal ball still isn’t working, so please provide the details I asked for in my previous post (obviously for the “outgoing” settings the “mailbox type” doesn’t apply - though the server name does). While on the incoming and outgoing server settings pages select the “next” (for both options under both the “wifi” that isn’t working and “4g” that is) and report the details of any error popups that show up.


the problem persist after installing the new beta version 5.909.
When I am in office with the wifi connection and I select “next” in the page “incoming server” i see the error “Setup could not finish - Cannot connect to host”. This problem persist from version 5.908
When I am out of the office the mail works without any problems.
The details:

  • K9 version = beta version 5.909 or 5.908
  • mail service provider =
  • mailbox type - imap/pop = imap
  • imap/pop server name =
  • security = SSL/TLS
  • port = 993
  • authentication (password type) setting = normal password

Is there any log that I can send you?


“Cannot connect to host” means your device can’t establish a connection to your mail server using the network it is currently connected to. If it works on one network but not another, the most likely cause is that something in that first network is blocking the connection to the mail server. You need to talk to whoever manages your office network.

Yes, I can ask.
But from release 5.907 and 5.908 what has changed in the comunication to the server?
Now I try to downgrade the software to release 5.907


Maybe something changed at your employer on 1/5 that brought on your problem. It might not have been caused by your phone.

Have you tried using K9 through a reputable VPN on your phone while on the wifi at work? This will probably block any work apps while on the work wifi. I’d guess though, that if your employer blocks outgoing mail connections, they’ll probably block outgoing VPN connections.

You’re right. I tried a VPN and now it works!
Now I ask my colleague to check the rules in our server.
Thank you