IMAP account missing folders

I hadn’t saved settings recently before the update, so I’m not sure I want to go back to the prior version. One critical problem is that the IMAP email is missing the sent folder. It’s not syncing. I am not using push. But, I need some of those sent emails, and they are not showing up.
All the sent folders of my POP accounts show properly.

I also didn’t have a recent saved settings from the old version before updating to 5.8. But I found that following the procedure outlined elsewhere worked for me and my 11 email accounts. I saved the settings using 5.802, installed the 5.6 apk and restored the settings. Of course I had to enter the passwords again but it worked fine.

FWIW, the straw that broke the camel’s back was that the update to 5.802 caused my battery to drain fast enough that my phone got pretty warm. Device care settings told me that it was K-9 using all the battery in the background. I’m back at 5.6 and happy again.

I did not have a battery drain problem, but I mostly use POP email, and turned off the push for the IMAP account.
Thank you for the info.

Did you update to 5.802? The original 5.8 didn’t have a battery drain problem but 5.802 did. Also, problems like battery drain can be device and even OS version specific so I can see where you might not hit it but I do. I’m using a Samsung S9+ with t-mobile’s android 10.

I seem to have 5.803.
Seems OK for battery drain.
If you are on Verizon, they force installed Digital Secure recently - it used half my battery in an hour. Can’t be uninstalled, but can be turned off.
I may go back to the old one.