How to stop K9 marking automatically messages as read

I use Thunderbird on PC (have done for probably 30 years) but recently found K9 as a Thunderbird-compatible mail reader for Android.

K9 has been working well, but I have one very serious problem with it. Unlike thunderbird, I haven’t managed to find an option to prevent K9 from automatically marking messages as read even though I’ve only glanced at it while on a train and decided it can be better handled when I get home.

The problem there is that when I get home, I probably don’t notice the message because it’s already marked as read. It therefore never shows up in Thunderbird as a message requiring attention…


  • If that option already exists, a search in options hasn’t found it, so the search might need improving. But I have also manually hunted through the options and still not found it.
  • if that option doesn’t currently exist, you should be aware that it’s an essential requirement for anybody who will want to use K9 alongside Thunderbird. But the same would also apply to anybody else that uses android as well as another mail reader (eg on a laptop) to read mail.

Settings - select your email/alias - Reading mail. Untick the box to “Mark as read”

1 Like

Thanks for the prompt reply.

As somebody who has more than one email address, I expected to find that setting (perhaps duplicated) under the general setting and would then apply to all accounts. But I’m glad to see that the setting exists, even though I have to do it in many places.

1 Like