How to stop K-9 Mail *ever* refreshing automatically?

I’m trying to make sure only distractions important enough to require immediate action — basically only calendar alerts and natural disaster warnings — ever produce audible alerts on my phone. So far I’ve set “Folder poll frequency” to “Never” and turned off “Poll when connecting for push” (I don’t understand what that even means, but it sounded relevant), but K-9 Mail still bugs me several times per day. How do I turn off any and all automatic syncing of email?

There’s a few ways you can accomplish this. If it’s just the notifications that bother you, there are per-account notification settings under Settings -> Account settings -> Notifications. Uncheck the “New mail notifications” setting and you should no longer get any audible or visible notifications for that account. Repeat for any other accounts you have in K-9.

If you actually want to stop all automatic network traffic / synchronization, you need to turn off both polling and pushing. The settings are under Settings -> Account settings -> Fetching mail. Set “Folder poll frequency” to Never, and set “Push folders” to None.

The “Poll when connecting for push” setting has to do with the way push notifications work in K-9. It relies in the IMAP IDLE connection feature, which holds a session open to allow the server to announce newly arrived messages to the device. But if this connection is lost, new messages that arrive before the push connection is re-established will not be sent over. The setting triggers a normal poll when a push IDLE connection is re-established to make sure that any missed messages get synced. The setting has no effect if push is disabled on an account.


Thank you, that should do the trick in terms of the notifications themselves.

Thank you! I wouldn’t have thought of disabling push folders to avoid getting new emails.

Thank you for the explanation!