How to deny question about allowing access to my contacts?


since a few weeks I use the k9 version 6.400.

When I start the app, there is the question that I need to allow the access to my contacts (for showing name suggestions and contact pictures). There is only an okay-button to click and no other button.

So I don’t want this and always need to tip anywhere else on the screen so this window disappears. This is a little bit annoying.

In the settings I didn’t find any general setting for denying this.

Please add a button for “no I don’t want this and please remember my decision” or something like this.

Or give me a solution here :slight_smile:

Thanks in advance.

Kind regards

Make sure to actually tap the dialog buttons, both in the “permission rationale” dialog displayed by K-9 Mail and the actual permission dialog displayed by Android. If you dismiss any of the dialogs by tapping outside the dialog, the same dialog will appear the next time you open the app.

I only have the K-9 Mail dialog button and there I have only the option “OK” and nothing else. Not even the Android
permission button is there.

Here a Screenshot:

After you tap the “OK” button in the pictured dialog, you should see the system’s permission dialog. If you don’t want to grant the permission, make sure to tap the corresponding button in the system dialog and don’t just dismiss it.

If you’re seeing the dialog in your screenshot, but no system permission dialog after tapping the “OK” button, it’s a bug in your Android version.


As an extension, in case this was not clear yet: Pressing “OK” on that dialog does not grant the permission. That dialog is just there for the explanation. The second dialog that comes after that is the actual permission request.

@cketti in case more users have trouble with this, maybe the dialog could say something like “grant permission on the next screen”. That makes it more clear that this is just the explanation screen.