GMX Problem to connect with K-9

Hello, i don’t know if this is a bug, but i can’t connect to my gmx accounts with k-9. I have two accounts. Both works with Thunderbird. I tried differnt settings. I use Imap

Server: or
SSL Port 993
Normal Password

K-9 runs on a Samsung S23 in the Knox area with the last Android System.

What could be the problem? Other mail accounts work.

My GMX account works fine on k-9, also with 993 and .net. I’m pretty sure I let k-9 do the initial setup itself and it found the correct settings.

First I tried the initial setup. I uninstalled K-9 and installed it again. But GMX wont work for me.

“wont work” isn’t very descriptive of the problem/issues you are encountering. You need to give a description of the problem, including any error messages you are getting.


The message is:
Einrichtung konnte nicht abgeschlossen werden.
Verbindung zum Server nicht möglich (Unable to connect)
Translated: Setup could not be completed.
Unable to connect to the server (Unable to connect)

Today I made a test. I installed it in the normal system (not Knox). And it connected directly. Then I reinstalled it in Knox and had the same problem as before. So it seems to be Knox. But I can not explain it.

Sure User Credentials Management (UCM) does not interfere while you input the credentials?

I solved the problem now. I uninstalled knox und made an fresh install. The KNOX before used an import from an older phone. After that i got no problems with K-9 mail. I would imagine that the certificates have not been updated. But i don’t know.

Very good for you. According to their documentation it could have only been that or very few other cases. One should always have the latest Knox suitable for their phone.

If you found the solution suitable, please mark the reply as solution.

1 Like