Gmail and Yahoo accounts set up issues

Hello :slight_smile:
I have hit some obstacles trying to use K-9 app on my Pixel phone running Lineage OS.

  1. With gmail I get error message - Username or password incorrect, invalid credentials. Needless to say that my log in details are for sure correct. I went under my gmail security settings and turned ON “less secure app access” and that did not help.
  2. With yahoo email I get a server issue message: set up could not finish : cannot connect to server. Here is what I have showing on the phone: IMAP server: imap.yahoo.ca, Security: SSL/TLS, Port:993

If anybody has any insights on this, I would greatly appreciate this. Thank you!

For GMail, you’ll probably need to set up an app-specific password. This is the case if you have any sort of two-factor authentication enabled on your account.

For Yahoo, the correct hostnames and ports are listed here:

https://en-global.help.yahoo.com/kb/SLN4075.html

Thank you Zootboy for assisting with this! Concerning gmail - the two factor authentication is disabled. I already checked. Concerning Yahoo - I have already followed similar links. I can only get as far as “incoming”, and all the information is the same as per instructions. Anything pass that point, I get error message “set up could not finish” Cannot connect to server. Your help is appreciated :slight_smile:

GMail also requires IMAP access to be enabled in its settings. In addition, you may need to use an app-specific password even if 2FA is disabled. Google has been moving to “lock down” password-only access methods as of late.

As for Yahoo, you might try both the STARTTLS and SSL/TLS options on both listed ports to see if one of those combinations works. Their page is a little ambiguous, but 587 is typically STARTTLS and 465 is typically SSL/TLS.

Hello

I had a similar problem with gmail : “Authentication plain NO” while the password was good.
I enabled 2FA and created an app password. K9-mail worked again.
Then I disabled 2FA and entered my password.
For now, K9-mail is still working.

Zootboy, you can’t use an app password if 2FA is disabled. The option is not available.

I have the same problem on Gmail. I fix activating the access IMAP on POP/IMAP configuration (https://mail.google.com/mail/u/0/#settings/fwdandpop) and allowing access to less security app on account’s configuration > security (https://myaccount.google.com/security?gar=1)