Fetching mails from GMX stopped working (Certificate error). Configuration fails (STARTTLS not available)

Hi, first things first: Thanks for this great app!

I have configured mutliple POP3 accounts from different providers, and all of a sudden my GMX accounts have stopped working. I’m using the exact same settings as before, and they are the same I’m using on my desktop pc, where the settings are still working flawlessly.

I’m now getting “Certificate error for xxx@gmx.de / Check your server settings” everytime K-9 Mail tries to automatically (every hour) or manually fetch the latest mails (GMX only, the other accounts are fine). In the incoming server settings, I’m no longer able to enter a configuration that will succeed in testing the connection. My settings (worked before and are still working in Evolution on Linux desktop) are:

POP3 server: pop DOT gmx DOT net (I cannot post otherwise because this is considered a link?)
Security: STARTTLS
Port: 110
Username: xxx@gmx.de
Authentication: Normal password
Password: the correct password
Client certificate: No client certificate

When clicking on “NEXT”, the following error message pops up:
“Setup could not finish
Cannot connect to server.
(STARTTLS connection security not available)”

I tried different settings without success. Using SSL on port 995 leads to “Cannot connect to server. (Unable to execute POP3 command)”.

K9 Mail 5.806 from Google Play.
Android 9

Are you aware of any GMX specific problems from other users? Google Play says K-9 Mail was last updated August 2021. The connection problems first occurred last week, so maybe GMX messed something up?

For me the GMX mail server supports STARTTLS just fine.

It is possible that your connections to the mail server are intercepted and changed so the announcement of the STARTTLS capability is removed. Are you using the TOR network, a VPN, or some kind of firewall software?

Same issue with me.
GMX and IONOS accounts using POP3 SSL/TLS port 995 stopped working since beginning of this week (unable to execute POP3 command). Gmail still working. Also had a Google-App-Update this weekend.
I changed nothing in the configuration.

K-9 version 5.806
Phone: Poco F2 pro
Android 11

See Can’t connect to POP3 server (IONOS, GMX, maybe others) · Issue #5879 · k9mail/k-9 · GitHub

You could try setting up the account to use IMAP. That’s a far better choice when using K-9 Mail anyway.

We’ll probably release a new beta version fixing the issue with POP3 later today.

1 Like

The latest beta version should fix the issue. Beta: K-9 Mail 5.910

Since this morning, i am observing exactly the same issue. Mail Provider GMX; POP3; no longer possible to receive e-mails. Didn’t do any changes to my settings. Switching to IMAP doesn’t help either.

What might be of interest: I tried to use Samsung Mail instead of K9; same problem– impossible to receive emails. This seems to indicate that the problem is located at the side of GMX.

All the best,

Same problem here since monday, without me changing anything config wise. Tried pop3 and imap with gmx now and neither works. Will see if I can get the beta version to confirm.

EDIT:5.910 fixed pop3 fetching for me. Good Job chketti :slight_smile:
(Google Playstore - opt in beta-programm - finickle a bit with searching for updates until it shows up)

I just received the update to K-9 Mail 5.807 via regular Google Play.
Receiving mails from GMX works fine again.
Thanks for your very quick reaction, bug fix AND regular release update, thumbs up!

1 Like