Failure to connect on setup

I use my K9 all the time on android. No problems until trying recently to add two accounts.

Today I tried to add two accounts, Yahoo and another on my own mail server and both fail to connect. Errors different but both seem related to authentication.

My account is on Apache typical IMAP mail server. I have three other accounts set up already and all work fine. Adding new one keeps saying cannot connect to server, host not found. I have quadruple checked settings and they are all correct. Exact same settings as in my Thunderbird on desktop work fine there.

Likewise my yahoo login is correct. Have tried that multiple times. email and passwords are correct.

Any ideas why KNOWN CORRECT settings will now refuse to connect to servers that I know are available for connection?

Any ideas most welcome.


Getting worse. Already existing accounts on my server as well as GMAIL are no longer connecting. Cannot send or receive any emails.

No settings changed. I have good internet. Can use other emails such as Proton and Tutanota and browse web. VPN disables. It’s just died!!

All loads accounts etc. bet any attempt to connect I get a TimeoutException

You probably have to add an App Password for each account both in Gmail + Yahoo since k9 and other mail clients are considered “unsafe”.
Check the Gmail/Yahoo help pages for guides on how to do that.

In the case of the problem with your own mail server, the error you indicate is “host not found”, which means that your mobile device can’t find a DNS record for your mail server. Try doing a DNS lookup for (an A-record for) your mail server’s name from your mobile device. If your mail server is local to your network and the DNS for it isn’t public the lookup will fail from a cell-data connection and also potentially from wi-fi, if that’s on a different network (depends on how things are configured).

That might make sense were it not for the fact that three other accounts on my mail server are working fine. DNS issue would block all my accounts not just the one.

you indicated that these accounts work fine … from your desktop. if the mobile device isn’t using the (exact) same connectivity as the desktop there could be a DNS issue that is causing this. even then, if you are using a *nix (e.g., linux) machine as your desktop you could have an entry in your /etc/hosts file, which of course your mobile device doesn’t have. as a first debug point, try a DNS lookup for your mail server from your mobile device.