Emails not sending

I am having a problem sending emails from K-9. I am using a BT smtp server and sending from my own domain email address via Android v11 and K-9 5.806. The setup follows BT instructions including SSL and port 465. The email appears to go OK without any error message, but in fact is not sent and appears in neither Outbox nor (mostly) Sent folders. I have a similar problem with a tablet on Android 7.0 and K-9 5.600 except that in this case outgoing emails are saved to the Sent folder but not actually sent or received by the intended recipient. Tbird works OK with the same mailboxes.

I have tried changing passwords but with no effect.

Any help would be appreciated.

Here’s roughly how K-9 Mail works:

  1. When hitting the send button in the compose screen, a message in the local “Outbox” folder is created.
  2. Messages in the “Outbox” folder are transmitted to the outgoing mail server.
    2a) If the outgoing mail server rejects the message, an error notification will be created.
    2b) If the outgoing server accepts the message, a copy of the message will be uploaded to the configured Sent folder (if there is none configured or Settings → [Account] → Sending mail → Upload sent messages is unchecked, there’s no upload happening). The sent message is then deleted from the “Outbox” folder.

When a message couldn’t be sent (either because of connectivity issues or a permanent error), it stays in the Outbox folder.


If you can’t find the message in the Outbox folder, it means your outgoing mail server has accepted the message for delivery. If it doesn’t arrive at the destination, there’s most likely an issue either at your email provider or at the recipient’s email provider.

If the message can’t be found in the Sent folder, it’s most likely a configuration issue. Check Settings → [Account] → Folders → Sent folder and Settings → [Account] → Sending mail → Upload sent messages.

1 Like

Thanks for this. The explanation of the mechanism makes sense. I have four accounts/mailboxes, of which three are POP3 and one is IMAP. On checking further I found that for two of the POP3 accounts there was no Outbox or Sent folder, just an inbox. I deleted and recreated these accounts and they returned with the full set of folders. On testing these now worked OK to send emails.

However the problem remains with the IMAP account. I have checked **Settings → [Account] → Folders → Sent folder where the folder is labelled ‘Sent’ on both devices; and Settings → [Account] → Sending mail → Upload sent messages , where on the phone , ‘Upload messages to Sent folder after sending’ is checked, and on the tablet, the item ‘Upload messages to Sent folder after sending’ does not appear to exist.

I use a redirection service that allows me to track messages through, and in no case were test messages shown as received.

Do we know of any problem with BT servers? While researching this problem I read that a (not precisely) similar problem was solved when BT ‘retrained’ their anti-spam measures.

1 Like

So you’re not getting an error notification when you press the send button in the compose screen? And the message doesn’t show up in either the Outbox or the Sent folder?

Can you please record a debug log? See LoggingErrors · k9mail/k-9 Wiki · GitHub

How does that work? You configured K-9 Mail to use that service as an outgoing mail server? Have you considered that it might be a problem with that service?

Thanks for this. Correct, there is no error notification on pressing the send button in the compose screen. As above, the message shows in the Sent folder on the tablet but not on the phone. I notice that there is no Outbox visible for this account within K-9 on the phone.

I have recorded a debug log but have not succeeded in accessing it. adb reports:
D:\Installation kits\Android\platform-tools>adb shell ps -A ¦ findstr k9
adb server version (40) doesn’t match this client (41); killing…

  • daemon started successfully
    ps: bad ¦

and

D:\Installation kits\Android\platform-tools>adb devices
adb server version (40) doesn’t match this client (41); killing…

  • daemon started successfully
    List of devices attached
    1a41dd0800c1adef device
    6TJBBQ5T99QKS8YT device

The redirection service works on inbound emails on my domain email accounts (being used for testing). Emails to my domain email addresses are redirected to my BT account email accounts. K-9 Mail outgoing actions should I assume be unaffected.

When re-testing with debug enabled, I sent an email from my IMAP account to both one of my own domain email addresses and the corresponding native BT address. With the phone, neither arrived. With the tablet, the email to the native BT address arrived but not the email to my domain, which is progress and suggests the redirection service may be part of the problem, at least while testing, as you suggest. The redirection tracking did not detect any incoming email in either case.

This shouldn’t happen. But when it does, you won’t be able to send messages. Please try removing the account, then add it again.

I created an issue in our bug tracker to better handle this situation in the future: Silent failure when sending a message and Outbox doesn't exist · Issue #5876 · k9mail/k-9 · GitHub

1 Like

Thank you. Removed and replaced account on phone, all folders present, outgoing email saved correctly and received at destination. I can take up any redirection issues elsewhere.

I guess this can be marked as solved?

Yes, for me at least, but there seems to remain a problem with the initial setup process which can allow required folders not to be created.